Skip to main content

New session rejected because of 50 session limit

  • January 31, 2014
  • 5 replies
  • 7 views

Meng_Mao
When trying to talk to Vertica, we get rejected with the following error.

Severity: FATAL, Message: New session rejected due to limit, already 50 sessions active, Sqlstate: 57V03, Routine: addClientSession, File: /scratch_a/release/vbuild/vertica/Session/SessionManager.cpp, Line: 544
 
I'm not aware of where the 50 session limit is set. When I look at the number of active sessions, it is well below below 50. Is there a way I can raise the limit on the cluster? Or is it baked in?

5 replies

Forum|alt.badge.img+2
  • Participating Frequently
  • January 31, 2014
There is a general parameter MaxClientSessions that controls the max number of client sessions for a single node. The default is 50. It can be changed via a select such as the following:
SELECT SET_CONFIG_PARAMETER ('MaxClientSessions', 100);

More info can be found in the Admin Guide under the "General Parameters"
and "Managing Sessions" pages.


Meng_Mao
  • Author
  • New Participant
  • January 31, 2014
Thanks! That does it for us.

Sashidhar_Arcot
Forum|alt.badge.img
  • Participating Frequently
  • February 6, 2014
.

PanduB
  • New Participant
  • January 17, 2024

Hi

We are NOT able to connect to Vertica for running below command. we are getting vsql: FATAL 4060: New session rejected due to limit, already 155 sessions active error when we try to connect to Vertica from AWS EC2 session manager.

SELECT SET_CONFIG_PARAMETER ('MaxClientSessions', 1000);

Please let me know what should be done in this case.

I also got location of the file where these session values are being stored

/proc/sys/fs/file-nr

This file is related to file-max and holds three values:

  • Number of allocated file handles
  • Number of used file handles
  • Maximum number of file handles

Let me know whether it can be manually changed ?


Bryan_H
Forum|alt.badge.img+2
  • Participating Frequently
  • January 17, 2024

You should be able to connect as dbadmin (administrator user), which can connect even when session limit is reached. If this is not the case, you may need to log onto a node and connect using vsql from a cluster node in order to raise the session limit with SET_CONFIG_PARAMETER.
The other setting for file handles in /proc can be set with ulimit as shown in the documentation, where we recommend increasing the user and system max file limits: https://docs.vertica.com/12.0.x/en/setup/set-up-on-premises/before-you-install/automatically-configured-os-settings/system-max-open-files-limit/