Hi all,
I’m having difficulties to install Vertica on top of Ubuntu server 14.04 in a Canonical Openstack environment.
I performed the necessary preparation steps. When I run install_vertica script, I get the following output:
root@vertica-ubuntu:/home/ubuntu# /opt/vertica/sbin/install_vertica --hosts 127.0.0.1 --deb /home/ubuntu/vertica_setup/vertica_8.0.1-0_amd64.deb
Vertica Analytic Database 8.0.1-0 Installation Tool
Error: 'NoneType' object has no attribute 'split'
Traceback (most recent call last):
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/install/__init__.py", line 1338, in run_install
options = option_parser()
File "/opt/vertica/share/eggs/vertica/install/__main__.py", line 255, in _parse_options
_include_ami_customization(parser, options)
File "/opt/vertica/share/eggs/vertica/install/__main__.py", line 264, in _include_ami_customization
cfg_checker.load()
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/install/ami_install_config.py", line 18, in load
self._meta_data.load(base_url)
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/system/aws_metadata.py", line 74, in load
self._harvest_metadata(meta_data_baseurl)
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/system/aws_metadata.py", line 91, in _harvest_metadata
meta_data_baseurl)
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/system/aws_metadata.py", line 202, in _get_macs
raw_macs = raw_macs.split()
AttributeError: 'NoneType' object has no attribute 'split'
Installation FAILED with errors.
Installation stopped before any changes were made.
Then I search on the net about this error and one recommendation was to use “--ignore-install-config” switch and I tried it:
root@vertica-ubuntu:/home/ubuntu# /opt/vertica/sbin/install_vertica --hosts 127.0.0.1 --deb /home/ubuntu/vertica_setup/vertica_8.0.1-0_amd64.deb --ignore-install-config
Vertica Analytic Database 8.0.1-0 Installation Tool
>> Validating options...
Mapping hostnames in --hosts (-s) to addresses...
>> Starting installation tasks.
>> Getting system information for cluster (this may take a while)...
Default shell on nodes:
127.0.0.1 /bin/bash
>> Validating software versions (rpm or deb)...
>> Beginning new cluster creation...
successfully backed up admintools.conf on 127.0.0.1
>> Creating or validating DB Admin user/group...
Successful on hosts (1): 127.0.0.1
Provided DB Admin account details: user = dbadmin, group = verticadba, home = /home/dbadmin
Creating group... Group already exists
Validating group... Okay
Creating user... User already exists
Validating user... Okay
>> Validating node and cluster prerequisites...
Prerequisites not fully met during local (OS) configuration for
verify-127.0.0.1.xml:
HINT (S0151): https://my.vertica.com/docs/8.0.x/HTML/index.htm#cshid=S0151
These disks do not have known IO schedulers: '/dev/vda1' ('vda') =
'none'
HALT (U9999): https://my.vertica.com/docs/8.0.x/HTML/index.htm#cshid=U9999
Unexpected error: 'NoneType' object has no attribute 'split'
System prerequisites failed. Threshold = WARN
Hint: Fix above failures or use --failure-threshold
Installation FAILED with errors.
****
AdminTools and your existing Vertica databases may be unavailable.
Investigate the above warnings/errors and re-run installation.
****
root@vertica-ubuntu:/home/ubuntu#
So as you can see from the output, installation is failing to start because of the same error, shown in yellow.
Can you help me on this matter?