Skip to main content

Restore Failed (Password file is not read/write protected).

  • June 20, 2018
  • 1 reply
  • 2 views

andre_silva
Forum|alt.badge.img

Hello,

I'm trying make a restore, but restore failed with error:

Password file [2017] is not read/write protected. It should be only readable/writable by admin user/group.

obs: 2017 is my password file name.

Has anyone had the same problem?
Thanks!!

1 reply

Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • June 25, 2018

Can you check the owner, group and permissions of the file?

Only the database administrator or members of that user's permission group can view the contents of the file. If you alter the file permissions from their default values, Vertica backup or restore actions fail with an error message.

Example of defaults:

[dbadmin@s18384357 ~]$ ls -lrt jim_password
-rw------- 1 dbadmin verticadba 35 Jun 25 16:07 jim_password

See:
https://my.vertica.com/docs/9.1.x/HTML/index.htm#Authoring/AdministratorsGuide/BackupRestore/PasswordConfigurationFileReference.htm