Skip to main content

service verticad status not OK

  • March 10, 2017
  • 4 replies
  • 23 views

qcai

Dear Support,

Vertica DB server hang, so customer committed cold shutdown, then start OS.
OS started successfully, but Vertica DB failed to start.
~~~
~]# /etc/init.d/verticad start
Vertica: start OK for users: dbadmin
[root@obrdb01 ~]# [ OK ]
[root@obrdb01 ~]#
[root@obrdb01 ~]# /etc/init.d/HPE_PMDB_Platform_Vertica status
HPE_PMDB_Platform_Vertica is stopped
[root@obrdb01 ~]# /etc/init.d/verticad status
Vertica: status not OK
[root@obrdb01 ~]#

Customer tried following:

[dbadmin@obrdb01 ~]$ id
uid=502(dbadmin) gid=502(dbadmin) groups=502(dbadmin)
[dbadmin@obrdb01 ~]$ service verticad start
Vertica: Password:
start not OK
[dbadmin@obrdb01 ~]$ service verticad status
Vertica: Password:
status not OK
[dbadmin@obrdb01 ~]$
~~~~~~~

We collected below info and attached vertica.log:
~~~~~~
[root@obrdb01 ~]# rpm -qa | grep vertica
vertica-7.1.2-0.x86_64

[dbadmin@obrdb01 ~]$ admintools -t list_allnodes
Node | Host | State | Version | DB
-----------------+--------------+-------+-------------------+------
v_pmdb_node0001 | 10.100.74.56 | DOWN | vertica-7.1.2.000 | pmdb
~~~~

Rgds,
Q

4 replies

ckotsidimos
Forum|alt.badge.img+1
  • Participating Frequently
  • March 10, 2017

try starting vertica from admintools
Login the su - dbadmin
Admintools
and start db from there


qcai
  • Author
  • New Participant
  • March 15, 2017

again it failed.

*** Starting database: pmdb ***
Starting nodes:
v_pmdb_node0001 (10.100.74.56)

    Starting Vertica on all nodes. Please wait, databases with large catalog                                                                                        s may take a while to initialize.

    Node Status: v_pmdb_node0001: (INITIALIZING)
    Node Status: v_pmdb_node0001: (INITIALIZING)
    Node Status: v_pmdb_node0001: (DOWN)
    Node Status: v_pmdb_node0001: (DOWN)
    Node Status: v_pmdb_node0001: (DOWN)
    Node Status: v_pmdb_node0001: (DOWN)
    Node Status: v_pmdb_node0001: (DOWN)
    Node Status: v_pmdb_node0001: (DOWN)
    Node Status: v_pmdb_node0001: (DOWN)
    Node Status: v_pmdb_node0001: (DOWN)
    Error starting database, no nodes are up

Press RETURN to continue


ckotsidimos
Forum|alt.badge.img+1
  • Participating Frequently
  • March 24, 2017

you will have to check the startup.log file
Maybe there is an issue with th epoc


Forum|alt.badge.img+2
  • Participating Frequently
  • March 28, 2017

Please check vertica.log and startup.log in catalog directory for more details on failure.