Skip to main content

[SOLVED] Error: cannot find which cluster host is the local host.

  • October 29, 2015
  • 3 replies
  • 22 views

ismael_vc

Hello everyone!

 

I've been trying recently to install Vertica on a 20 node CentOS 6 cluster, I have installed the dependencies (in this case only the package dialog), after that I run on the master node:

 

 

 rpm -Uvh vertica-7.2.0-0.x86_64.RHEL6.rpm

And it finishes successfuly, but after that when I try to run:

 

 

[root@hd0 ~]# /opt/vertica/sbin/install_vertica --hosts hd1,hd2,hd3,hd4,hd5,hd6,hd7,hd8,hd9,hd10,hd11,hd12,hd13,hd14,hd15,hd16,hd17,hd18,hd19

I get into this problem and I haven't been able to figure it out yet (example output):

 

[root@hd0 ~]# /opt/vertica/sbin/install_vertica --hosts hd1,hd2,hd3,hd4,hd5,hd6,hd7,hd8,hd9,hd10,hd11,hd12,hd13,hd14,hd15,hd16,hd17,hd18,hd19
Vertica Analytic Database 7.2.0-0 Installation Tool


>> Validating options...


Mapping hostnames in --hosts (-s) to addresses...
hd1 => 555.555.555.551
hd2 => 555.555.555.552
hd3 => 555.555.555.553
hd4 => 555.555.555.554
hd5 => 555.555.555.555
hd6 => 555.555.555.556
hd7 => 555.555.555.557
hd8 => 555.555.555.558
hd9 => 555.555.555.559
hd10 => 555.555.555.510
hd11 => 555.555.555.511
hd12 => 555.555.555.512
hd13 => 555.555.555.513
hd14 => 555.555.555.514
hd15 => 555.555.555.515
hd16 => 555.555.555.516
hd17 => 555.555.555.517
hd18 => 555.555.555.518
hd19 => 555.555.555.519
Error: cannot find which cluster host is the local host.
Hint: Is this node in the cluster? Did its IP address change?
Installation FAILED with errors.

Installation stopped before any changes were made.

I just made the Julia language work across all the nodes (which makes me think ssh and other configs are fine) so I don't know what is Vertica trying to find out.

 

[root@hd0 ~]# julia -p 1 --machinefile nodes --quiet
julia> nprocs()
40

Where nodes is simply a file that lists the same hosts that are listed in the install_vertica command (2 workers per node).

 

Could someone help me figure out the source of this problem?

 

Thanks in advance, cheers!

 

 

3 replies

ismael_vc
  • Author
  • New Participant
  • October 29, 2015

I had to also add the master node to the list of hosts.


pios
  • New Participant
  • February 9, 2016

How to solve this problem?

 

 


Thakur
Forum|alt.badge.img
  • Participating Frequently
  • February 9, 2016

please pass the parameter " rpm " with full folder path and also include hd0 in the list of hosts

 

# /opt/vertica/sbin/install_vertica --hosts host_list --rpm package_name --dba-user dba_username