Skip to main content

SystemConfigController ERROR - configuration

  • February 26, 2019
  • 3 replies
  • 6 views

Mario

Hello Everyone

I got a problem when I start to configure the Management Console (the version of Vertica is 9.2). The installation of RPM was successful, and when I access to MC by the browser, configure the parameter are required, but when I finish the configuration the next messages appears:
Please wait while the server is restarting. You will be redirected to the login screen once the server is up and running.
Waiting to reconnect...

After a few seconds, the configuration wizard starts again.

In the log, I just see these lines, but dont show more description:

================================================================
26 Feb 2019 10:56:01,457 [qtp711767240-106 - /webui/systemConfig/finish?1551200170406] AppMetaDataRepositoryServiceImpl INFO - initial user successfully inserted
26 Feb 2019 10:56:01,539 [qtp711767240-106 - /webui/systemConfig/finish?1551200170406] AppServerRebootService INFO - Performing system configuration. A reboot of the MC will be necessary if this works.
26 Feb 2019 10:56:16,576 [qtp711767240-106 - /webui/systemConfig/finish?1551200170406] SystemConfigController ERROR - configuration failed.. factory reset.

================================================================

I tried to find info about this line but I don't have luck
"SystemConfigController ERROR - configuration failed.. factory reset"

Any help you can give me I will thank you.

Kind regards!

3 replies

Mario
  • Author
  • New Participant
  • February 28, 2019

SOLVED:

After a day of exhausting testing, I see the error is a generic message for any error that happened, but in this case, no more information was shown. On one of my tries, I uninstalled MC 9.2 an install version 9.0.1. This version has more detail of the error in "startup.log" file. Where I can see the "groupID" is wrong (the one I put in the wizard of the initial configuration the MC) so the log prints the error: "Group doesn't exist". Something that version 9.2 it did not it
After I see that, I put the correct value and the wizard finish successfully.

Now I asking me how can I change the level of the log of the MC? any tip will be welcome.


Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • February 28, 2019

You can change the MC log level in the /opt/vconsole/temp/webapp/WEB-INF/classes/log4j.xml file.

Line 26:

[dbadmin@s18384357 ~]$ grep "<logger name=\"com.vertica.admin.tools.webui\">" /opt/vconsole/temp/webapp/WEB-INF/classes/log4j.xml -n -A 1
25:     <logger name="com.vertica.admin.tools.webui">
26-             <level value="INFO" />

Log levels:

  1. DEBUG: Show more about implementation detail sql statement, object information
  2. INFO: For tracing the call flow. informative
  3. WARN: Detects the vertica database errors, system close to the limit
  4. ERROR: MC system error that will cause it shut down

Make sure you make a copy of the original for a backup! Also, changing the log level could cause your log file to get very large!


Mario
  • Author
  • New Participant
  • February 28, 2019

Excellent Jim, I thank you for sharing the knowledge.