Skip to main content

Transparent Huge Pages advice on Oracle Linux with Redhat Kernel

  • January 4, 2019
  • 3 replies
  • 13 views

mflower
Forum|alt.badge.img
I have a customer who is planning to upgrade both Vertica and their O/S.
They're moving to Oracle Linux 7.4 , with Red Hat Kernel (3.10.0-693.el7.x86_64)

They want to know what is the advice for Transparent Huge Pages (THP)? Based on the docs, for Red Hat 7/CentOS 7 and Amazon Linux 2.0 you must enable transparent hugepages, and for other operating systems it is recommended that THP is not enabled.
https://my.vertica.com/docs/latest/HTML/Content/Authoring/InstallationGuide/BeforeYouInstall/transparenthugepages.htm

Does this mean that they should not enable THP (since they'll be running Oracle Linux)?
Or since they're also planning to use the Red Hat Kernel, does this mean that they should enable THP?

Happy New Year, Mike


Michael Flower | EMEA Vertica Systems Engineer
Mobile: +44 7793 757 623
Michael.Flower@microfocus.com

[cid:image001.png@01D4703B.DE7DBA30]
Powering the Leading Data-Driven Organisations
www.vertica.com

3 replies

Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • January 8, 2019

Hi, I'm guessing since you are using the RHEL Kernel on OEL, you'd follow Vertica's recommendation for RHEL :)

We should be able to test that theory by running the Vertica installer on OEL 7.

According to the doc, for Red Hat 7 we must enable transparent hugepages. If its not enabled the installer should report the error with the identifier: S0312.

Here is a test on OEL 7.3 with the RHEL Kernel where transparent hugepages is set to NEVER...

[root@vbgeneric ~]$ cat /etc/oracle-release
Oracle Linux Server release 7.3

[root@vbgeneric ~]$ cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.3 (Maipo)

[root@vbgeneric ~]# rpm -Uvh vertica-9.2.0-2.x86_64.RHEL6.rpm
Preparing...                          ################################# [100%]
Updating / installing...
   1:vertica-9.2.0-2                  ################################# [100%]

Vertica Analytic Database V9.2.0-2 successfully installed on host vbgeneric

To complete your NEW installation and configure the cluster, run:
 /opt/vertica/sbin/install_vertica

To complete your Vertica UPGRADE, run:
 /opt/vertica/sbin/update_vertica

----------------------------------------------------------------------------------
Important
----------------------------------------------------------------------------------
Before upgrading Vertica, you must backup your database.  After you restart your
database after upgrading, you cannot revert to a previous Vertica software version.
----------------------------------------------------------------------------------

View the latest Vertica documentation at http://my.vertica.com/docs/

[root@vbgeneric ~]# /opt/vertica/sbin/install_vertica -s 10.0.2.15 -T
Vertica Analytic Database 9.2.0-2 Installation Tool

Validating options...

Mapping hostnames in --hosts (-s) to addresses...

Starting installation tasks.
Getting system information for cluster (this may take a while)...

Default shell on nodes:
10.0.2.15 /bin/bash

Validating software versions (rpm or deb)...

Beginning new cluster creation...

successfully backed up admintools.conf on 10.0.2.15

Creating or validating DB Admin user/group...

Password for new dbadmin user (empty = disabled)
Successful on hosts (1): 10.0.2.15
    Provided DB Admin account details: user = dbadmin, group = verticadba, home = /home/dbadmin
    Creating group... Adding group
    Validating group... Okay
    Creating user... Adding user
    Validating user... Okay

Validating node and cluster prerequisites...

Prerequisites not fully met during local (OS) configuration for
verify-10.0.2.15.xml:
    HINT (S0305): https://my.vertica.com/docs/9.2.x/HTML/index.htm#cshid=S0305
        TZ is unset for dbadmin. Consider updating .profile or .bashrc
    HINT (S0041): https://my.vertica.com/docs/9.2.x/HTML/index.htm#cshid=S0041
        Could not find the following tools normally provided by the mcelog
        package: mcelog
    WARN (N0010): https://my.vertica.com/docs/9.2.x/HTML/index.htm#cshid=N0010
        Linux iptables (firewall) has some non-trivial rules in tables: mangle,
        filter
    WARN (S0112): https://my.vertica.com/docs/9.2.x/HTML/index.htm#cshid=S0112
        vm.swappiness is higher than recommended: your 30 > 1
    FAIL (S0150): https://my.vertica.com/docs/9.2.x/HTML/index.htm#cshid=S0150
        These disks do not have 'deadline' or 'noop' IO scheduling: '/dev/sdb'
        ('sdb') = 'cfq'
    FAIL (S0312): https://my.vertica.com/docs/9.2.x/HTML/index.htm#cshid=S0312
        Transparent hugepages is set to 'never'. Must be 'always'.

System prerequisites failed.  Threshold = WARN
        Hint: Fix above failures or use --failure-threshold

Installation FAILED with errors.

****
AdminTools and your existing Vertica databases may be unavailable.
Investigate the above warnings/errors and re-run installation.
****

The installer reported issue S0312!

Conclusion:
You should "Enable" Transparent hugepages for OEL 7.x when using the RHEL Kernel!


DaveT
Forum|alt.badge.img
  • Participating Frequently
  • January 8, 2019

I agree with that. I have a customer who switched from RHEL to OEL and we used same settings.


mflower
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • January 10, 2019

Hello Jim and DaveT,
Thanks very much for your replies.
Much appreciated, Mike