Skip to main content

Unable to bind server on port 5433 when starting DB

  • April 28, 2017
  • 2 replies
  • 24 views

info4km

I just had the database running. I restarted the server and now I am receiving the following error in the dbLog file, "FATAL: Unable to bind server on port 5433". Any ideas what would cause this?
Thanks in advance
KM

2 replies

myfriendbarley
Forum|alt.badge.img
  • Participating Frequently
  • April 28, 2017

had you enabled the Vertica load balancer?


RaghavA
Forum|alt.badge.img
  • Participating Frequently
  • April 30, 2017

Hi info4km,

It appears that vertica cluster is not able to bind itself with port 5433 ( default ). Did you have a look in your vertica.log file and also check /var/log/messages file. To see any abnormality.

Can you verify following points to see if all configuration is in its place ?

I hope you running this system over Linux flavour.

1) Verify the port number in your admintools.conf file.
2) Can you see if, port 5433 is in listening mode or not ?

netstat -utln | grep 5433

3) if you cannot see it in netstat output. Check it is enabled in your /etc/services file.

Regards,
Raghav