Skip to main content
Question

Unable to create database - Vertica 10.1 with RHEL8

  • February 24, 2021
  • 4 replies
  • 6 views

smug

Hi, I've already searched the forum and tried the said 'solutions' but my problem still persists and I'm unable to create a database.
I'm using Vertica 10.1 with RHEL8 as a virtual machine and trying to setup a single node. I've added my local IP to /etc/hosts with the proper hostname, installation works fine using the install_script with --hosts flag but as soon as I create a database using adminTools, I get the 'load the startup information from the bootstrap node.' error. I've tried changing the limits of the open file but the changes don't get reflected still shows 1024 with ulimit -n. Below is the adminTools log file.

2021-02-24 12:03:51.169 admintools/10243:0x7f1159bfb700 [at_command.to_subprocess_invocation] <INFO> Command: [/opt/vertica/oss/python3/bin/python3 -m vertica.engine.api.at_runner --no-prompt --module vertica.engine.api.move_staged_files]; input: [#{"staged_file": "/tmp/vstage-073590e5-1ef9-4766-ae2c-94dc609676a4/file", "dest_path": "/opt/vertica/config/d5415f948449e9d4c421b568f2411140.dat", "remove_parent_dirs": true, "untar_file": false, "__rollback__": false, "__protocol__": "1.0"}]
2021-02-24 12:03:51.260 at_exec/10516:0x7f4f363b8740 [root.setup_custom_logging] <INFO> New log for 'at_exec'
2021-02-24 12:03:51.260 at_exec/10516:0x7f4f363b8740 [root.setup_custom_logging] <INFO> sys.argv: '/opt/vertica/oss/python3/lib/python3.7/site-packages/vertica/engine/api/at_runner.py' --no-prompt --module 'vertica.engine.api.move_staged_files'
2021-02-24 12:03:51.262 at_exec/10516:0x7f4f363b8740 [ATRunner.exec_module] <INFO> running: <ATCommand> module=vertica.engine.api.move_staged_files version=1.0 args={"staged_file": "/tmp/vstage-073590e5-1ef9-4766-ae2c-94dc609676a4/file", "dest_path": "/opt/vertica/config/d5415f948449e9d4c421b568f2411140.dat", "remove_parent_dirs": true, "untar_file": false}
2021-02-24 12:03:51.263 at_exec/10516:0x7f4f363b8740 [ATRunner.exec_module] <INFO> result: <ATResult> status=Completed host=None content={"staging_dir_removed": true, "runner_ack": true} error_message=None
2021-02-24 12:03:51.278 admintools/10243:0x7f115ef9e740 [adminCtrl.infoBox] <INFO> infobox(Failed to load the startup information from the bootstrap node.
Hint: Are your resource limits for new processes correct?

4 replies

SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 24, 2021

did you install libnsl package on your VM? Can you share me the contents of the limits.conf?

cat /etc/security/limits.conf


EmmanuelG
  • New Participant
  • January 29, 2024

Any comment or advise? I get the same error and I can't fix it


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • January 29, 2024

Can you share me the contents of the limits.conf?


mosheg
Forum|alt.badge.img+2
  • Participating Frequently
  • January 30, 2024

When encountering a database startup error:
Failed to load the startup information from the bootstrap node.
Hint: Are your resource limits for new processes correct?

The user process limit must be high enough to allow for the many threads opened by Vertica.
The recommended limit is the amount of RAM in MB and must be at least 1024.
To manually set the user process limit:
Run ulimit -u as the dbadmin user to determine the current limit.
If the limit is not the amount of memory in MB on the server, then edit/add the following line to /etc/security/limits.conf.
Replace 4096 with the amount of system memory, in MB, on the server.
dbadmin - nproc 4096

See: https://docs.vertica.com/24.1.x/en/setup/set-up-on-premises/before-you-install/automatically-configured-os-settings/user-process-limit/