Skip to main content

Unable to create first database in Vertica (on CentOS)

  • November 25, 2014
  • 15 replies
  • 56 views

Jinitha_Ginacha
Forum|alt.badge.img
I am new to vertica. I just installed vertica on my CentOS and I was able to open the adminTools UI. Soon after I give the password to create a new(my first) database. I get the following error.

admintools failed to create an interface object.
Please resize your window to a larger width and height.

This is the content of my admintools.conf file.

cat admintools.conf[Configuration]
last_port = 5433
tmp_dir = /tmp
default_base = /home/dbadmin
format = 3
install_opts = --hosts '127.0.0.1' --dba-user vertica --dba-user-password '*******'
spreadlog = False
controlsubnet = default
controlmode = broadcast

[Cluster]
hosts =

[Nodes]

Content of logs:

Nov 25 14:07:07  [18217] NEW LOG: /opt/vertica/bin/adminTools
Nov 25 14:07:07  [18217] [adminExec.__init__] Unique Ports: False
Nov 25 14:07:07  [18217] [isOkToRun] owner of admintools.conf (dbauser) is vertica.
Nov 25 14:07:07  [18217] [adminTools] Starting admin tools (['/opt/vertica/bin/adminTools'])...
Nov 25 14:07:07  [18217] [adminTools] Use unique ports = False
Nov 25 14:07:07  [18217] [adminTools] Configuration=
DBinclude.ADMINTOOLS_CONF=/opt/vertica/config/admintools.conf
DBinclude.ADMIN_DIR=/opt/vertica/bin
DBinclude.CHECK_FAILED=-1
DBinclude.CONFIG_DIR=/opt/vertica/config
DBinclude.CONFIG_INFO_DIR=/opt/vertica/config/configInfo
DBinclude.CONFIG_SHARE_DIR=/opt/vertica/config/share
DBinclude.CONFIG_USER_DIR=/opt/vertica/config/users
DBinclude.DB_DIR=/opt/vertica
DBinclude.DBname=<module 'vertica.config.DBname' from '/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/config/DBname.pyc'>
DBinclude.DEFAULT_RESTART_POLICY=ksafe
DBinclude.HELP_DIR=/opt/vertica/bin/help
DBinclude.LCHK_DIR=/opt/vertica/bin
DBinclude.LICENSE_KEY=/opt/vertica/config/share/license.key
DBinclude.LOG=0
DBinclude.LOG_DIR=/opt/vertica/log
DBinclude.MAX_KSAFETY=2
DBinclude.NAG_COUNT=0
DBinclude.NAG_FLAG=0
DBinclude.NAG_MSG={}
DBinclude.OLD_SPREAD_CONF=/opt/vertica/config/vspread.conf
DBinclude.OSNAME=RHEL5
DBinclude.OSS_DIR=/opt/vertica/oss
DBinclude.OS_DEBIAN=7
DBinclude.OS_DEBIAN_S=DEBIAN
DBinclude.OS_FEDORA=4
DBinclude.OS_FEDORA_S=FEDORA
DBinclude.OS_RHEL4=1
DBinclude.OS_RHEL4_S=RHEL4
DBinclude.OS_RHEL5=5
DBinclude.OS_RHEL5_S=RHEL5
DBinclude.OS_SUSE=3
DBinclude.OS_SUSE_S=SUSE
DBinclude.OS_UNSUPPORT=0
DBinclude.PACKAGES_DIR=/opt/vertica/packages
DBinclude.PACKAGE_DESC_FILE=package.conf
DBinclude.PACKAGE_INSTALL_SCRIPT=ddl/install.sql
DBinclude.PACKAGE_ISINSTALLED_SCRIPT=ddl/isinstalled.sql
DBinclude.PACKAGE_UNINSTALL_SCRIPT=ddl/uninstall.sql
DBinclude.PYTHON_BINARY=/opt/vertica/oss/python/bin/python
DBinclude.RESTART_POLICY_LIST=('never', 'ksafe', 'always')
DBinclude.SCRIPT_DIR=/opt/vertica/scripts
DBinclude.SHARE_DIR=/opt/vertica/share
DBinclude.TMP_DIR=/tmp
DBinclude.VERTICA_EGGS=/opt/vertica/share/eggs
DBinclude.adminToolErrorLog=/opt/vertica/log/adminTools-vertica.errors
DBinclude.adminToolLog=/opt/vertica/log/adminTools-vertica.log
DBinclude.adminToolLogUser=vertica
DBinclude.agentToolLog=/opt/vertica/log/agentTool-vertica.log
DBinclude.binDir=/opt/vertica/bin
DBinclude.binPath=/opt/vertica/bin/vertica
DBinclude.binPathCmdSetting=PATH=/opt/vertica/bin:$PATH; export PATH
DBinclude.commands=<module 'commands' from '/opt/vertica/oss/python/lib/python2.7/commands.pyc'>
DBinclude.copy=<module 'copy' from '/opt/vertica/oss/python/lib/python2.7/copy.pyc'>
DBinclude.dbDesignerConfig=/opt/vertica/config/configInfo/dbDesignerConfig
DBinclude.designParamsFile=design_params.txt
DBinclude.designParamsFileSuffix=_params.txt
DBinclude.designSchemaFileSuffix=_schema.xml
DBinclude.designerDiagManifest=/opt/vertica/log/DesignerDiagManifest.txt
DBinclude.designerErrorFile=designer_error.msg
DBinclude.designerLog=designer.log
DBinclude.getStringRep=<function getStringRep at 0x13070c8>
DBinclude.glob=<module 'glob' from '/opt/vertica/oss/python/lib/python2.7/glob.pyc'>
DBinclude.help_url=<function help_url at 0x13071b8>
DBinclude.libDir=/opt/vertica/lib
DBinclude.os=<module 'os' from '/opt/vertica/oss/python/lib/python2.7/os.pyc'>
DBinclude.pwd=<module 'pwd' (built-in)>
DBinclude.re=<module 're' from '/opt/vertica/oss/python/lib/python2.7/re.pyc'>
DBinclude.redesignParamsFile=redesign_params.txt
DBinclude.rpmDestFile=/tmp/dbRPM.rpm
DBinclude.rpmFC4_SrcInfoFile=/opt/vertica/config/configInfo/rpmFC4Info
DBinclude.rpmRHEL_SrcInfoFile=/opt/vertica/config/configInfo/rpmRHELInfo
DBinclude.rpmSUSE_SrcInfoFile=/opt/vertica/config/configInfo/rpmSUSEInfo
DBinclude.sbinDir=/opt/vertica/sbin
DBinclude.sys=<module 'sys' (built-in)>
DBinclude.uiMgrInput=None
DBinclude.uiMgrLog=/opt/vertica/log/uiMgr-vertica.log

Nov 25 14:07:07  [18217] [adminExec.__init__] Unique Ports: False
Nov 25 14:07:07  [18217] [adminExec.setInteractive] setting to True
Nov 25 14:07:07  [18217] [isOkToRun] owner of admintools.conf (dbauser) is vertica.

Any help on this would be greatly appreciated ...


15 replies

MAYANK_1
  • New Participant
  • November 25, 2014
Which version of Vertica are you using ?
Are you using dbadmin user to connect to Admintool utility ?


Jinitha_Ginacha
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • November 25, 2014
Hi Mayank.. Thanks for replying...

It's Vertica Analytic Database v7.1.1-0.

I had created a user- 'vertica' while installation and tried to create the DB using this user.

Raul_1
Forum|alt.badge.img
  • Participating Frequently
  • November 25, 2014

Can you try creating the DB from the command line -
admintools -t create_db -s <hostname> -d <DB-NAME>
This should populate the admintools.conf, which has sometimes addressed this issue.

Jinitha_Ginacha
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • November 26, 2014
Hi Raul.. Thanks for replying.. I tried as per your suggestion. Please see the error i get now in the attached image.
image .

This CentOS machine is not connected to any network. Could this be a cause?

anmol_koul
Forum|alt.badge.img+1
  • Participating Frequently
  • November 26, 2014
Hi,

was it a single node installation or a cluster?

id10t
Forum|alt.badge.img
  • Participating Frequently
  • November 26, 2014
Hi!

HOST isn't correct. Its not your problem, its awful python programmers at HP Vertica.

Let me show(emulate) your issue:
https://www.dropbox.com/s/pust0hyvh8xloo0/socket.pdf?dl=0
Ha! Same error and error message!

From example you can see, that the problem in python code, that process a wrong host name. Awful python programmers, Im too tired to fix their bugs.

What is your host name? You can find it with 'hostname' command:
$ hostname
synapse

Daniel

Jinitha_Ginacha
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • November 26, 2014
my hostname is seen in the screen- TRVDBPHILIPSIGSDEVVL

Jinitha_Ginacha
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • November 26, 2014
Its on just one node in this case.

id10t
Forum|alt.badge.img
  • Participating Frequently
  • November 26, 2014
Hi!

so try to define a host (if it single node installation):
-s '127.0.0.1'
PS
You asked for help , and I have to strain my eyes and try to discover what is written there in the picture? Do you have a conscience? Its so hard to do COPY/PASTE or to run command that I asked.

Raul_1
Forum|alt.badge.img
  • Participating Frequently
  • November 26, 2014
...or you can ensure that the name is resolved to an IP address in /etc/hosts

Jinitha_Ginacha
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • November 27, 2014
sorry that i cudnt copy paste it as my CentOS machine is a remote machine.

Jinitha_Ginacha
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • November 27, 2014
This is the error now.

[vertica@TRVDBPHILIPSIGSDEVVL bin]$ adminTools -t create_db -s 127.0.0.1 -d IGS_Master
Info: no password specified, using none
Database with 1  or 2 nodes cannot be k-safe and it may lose data if it crashes
Error: host 127.0.0.1 does not appear to be part of this cluster.
Make sure you are using the correct hostname.

Content of host file.


[u22299@TRVDBPHILIPSIGSDEVVL ~]$ cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6



id10t
Forum|alt.badge.img
  • Participating Frequently
  • November 27, 2014
Hi!

Content of section "Cluster" are empty in your /opt/vertica/config/admintools.conf config file. Try manually to fill this sections:
[Cluster]
hosts = 127.0.0.1
And try to run install and if it fails post an error message.

Regards, Idiot.

Jinitha_Ginacha
Forum|alt.badge.img
  • Author
  • Participating Frequently
  • November 27, 2014
changed the conf file and tried to install again.

[root@TRVDBPHILIPSIGSDEVVL sbin]# ./install_vertica --hosts 127.0.0.1 --dba-user vertica --dba-user                                                          -password verticaVertica Analytic Database 7.1.1-0 Installation Tool


>> Validating options...


Mapping hostnames in --hosts (-s) to addresses...

>> Starting installation tasks.
>> Getting system information for cluster (this may take a while)...

Default shell on nodes:
127.0.0.1 /bin/bash

>> Validating software versions (rpm or deb)...


>> Beginning new cluster creation...

backing up admintools.conf on 127.0.0.1

>> Creating or validating DB Admin user/group...

Successful on hosts (1): 127.0.0.1
    Provided DB Admin account details: user = vertica, group = verticadba, home = /home/vertica
    Creating group... Group already exists
    Validating group... Okay
    Creating user... User already exists
    Validating user... Okay


>> Validating node and cluster prerequisites...

Prerequisites not fully met during local (OS) configuration for
verify-127.0.0.1.xml:
    HINT (S0305): https://my.vertica.com/docs/7.1.x/HTML/index.htm#cshid=S0305
        TZ is unset for vertica. Consider updating .profile or .bashrc
    HINT (S0041): https://my.vertica.com/docs/7.1.x/HTML/index.htm#cshid=S0041
        Could not find the following tools normally provided by the mcelog
        package: mcelog
    FAIL (S0150): https://my.vertica.com/docs/7.1.x/HTML/index.htm#cshid=S0150
        These disks do not have 'deadline' or 'noop' IO scheduling: '/dev/sda1'
        ('sda') = 'cfq', '/dev/sda2' ('sda') = 'cfq'
    FAIL (S0020): https://my.vertica.com/docs/7.1.x/HTML/index.htm#cshid=S0020
        Readahead size of sda (/dev/sda1,/dev/sda2) is too low for typical
        systems: 256 < 2048
    FAIL (S0030): https://my.vertica.com/docs/7.1.x/HTML/index.htm#cshid=S0030
        ntpd process is not running: ['ntpd', 'ntp']
    FAIL (S0081): https://my.vertica.com/docs/7.1.x/HTML/index.htm#cshid=S0081
        SELinux appears to be enabled and not in permissive mode.
    FAIL (S0310): https://my.vertica.com/docs/7.1.x/HTML/index.htm#cshid=S0310
        Transparent hugepages is set to 'always'. Must be 'never' or 'madvise'.

System prerequisites failed.  Threshold = WARN
        Hint: Fix above failures or use --failure-threshold

Installation FAILED with errors.

****
AdminTools and your existing Vertica databases may be unavailable.
Investigate the above warnings/errors and re-run installation.
****



id10t
Forum|alt.badge.img
  • Participating Frequently
  • November 27, 2014
Hi!

So now everything is ok - problem is solved, just fix all your "FAILS". Don't ask us what "FAIL"s means - read the docs(each "FAIL" provides a link with error description and solution).


SOLVED


Regards, idiot.