Skip to main content

Unable to Import Existing Vertica Cluster via Management Console

  • May 20, 2019
  • 31 replies
  • 6 views

Show first post

31 replies

Bryan_H
Forum|alt.badge.img+2
  • Participating Frequently
  • July 16, 2019

My MC and Vertica server are on same box - when you import DB, do you enter the adapter IP address first in the four boxes, then API key, then user/password?
The next step is to increase logging on agent. This requires an edit to /opt/vertica/agent/simply_fast.py - change the line rest_handler.setLevel(logging.INFO) to rest_handler.setLevel(logging.DEBUG) then restart vertica_agent. This will greatly increase logging in all components but hopefully agent.log or vertica.log will then show the root cause.


verban
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • July 17, 2019

I found the root cause B)
it seems vconsole query user for authentication like this:
select * from users where user_name = 'dbadmin';'
In this form:

And i got this error on vertica.log:

But it should be:
select * from v_catalog.users where user_name = 'dbadmin';'

Because** i have a 'users' table in my database **

I changed my table name temporarily and successfully imported!

Finally Fixed :)))


Bryan_H
Forum|alt.badge.img+2
  • Participating Frequently
  • July 17, 2019

Thank you for your work in finding the root cause! I'll file a ticket to have this fixed in MC. Glad to hear it's finally working!


Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • July 17, 2019

@verban - Wow! We should have thought of that as a possibility earier! Thanks for hanging in there and helping us find this bug.


Bryan_H
Forum|alt.badge.img+2
  • Participating Frequently
  • July 18, 2019

@marry009 The link in your comment doesn't work. Could you post a screenshot oand also the output of the error from /opt/vconsole/log/mc/mconsole.log on the MC instance? Thanks!


verban
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • September 2, 2020

@Jim_Knicely said:
@verban - Wow! We should have thought of that as a possibility earier! Thanks for hanging in there and helping us find this bug.

The issue still existing in latest version (vertica-console_10.0.0-0_amd64.deb)
It select from public.users instead of v_catalog_users!!