Skip to main content

Unable to read bootstrap node metadata

  • July 20, 2014
  • 19 replies
  • 54 views

Victor_Melnik
Hi, everyone.

I'm trying to create database through adminTools and have a next error:

*** Creating database mvl ***
127.0.0.1 OK [vertica][(7, 0, 1)][000][all]
Creating database mvl
Starting bootstrap node v_mvl_node0001 (127.0.0.1)
ERROR: Unable to read bootstrap node metadata

Any ideas, guys?
I'm using VirtualBox + Ubuntu 12.04 + Vertica Server 7

19 replies

Rahul_Choudhary
Forum|alt.badge.img
  • Participating Frequently
  • July 21, 2014
Hi Victor

Did you notice any particular error/warning messages apart from this while creating db?Can you provide the admintools-dbadmin.log file in order to check this issue further?

Regards
Rahul

Siddarth
Forum|alt.badge.img+1
  • Participating Frequently
  • July 21, 2014
Try rebooting your VM and then try to create the database.

Victor_Melnik
  • Author
  • New Participant
  • July 25, 2014
Hi, Siddarth.

I've tried your variant, but it haven't solved my problem.

Lasantha_Fernan
Hi,

Have you tried increasing the file limits to around 65K. You can use 'ulimit -n' or edit /etc/security/limits.conf.

I recently ran into a similar issue where a perfectly running Vertica did not start working after doing an OS upgrade, and the cause was the limits.conf file was replaced during upgrade, wiping out previous configs for file limits.

Arvind_Kumar
Forum|alt.badge.img+1
  • Participating Frequently
  • August 28, 2014
Hi look for your /etc/hosts

put your ip and hostname there....vertica is not able to resolve your hostname and ip 

so correct your /etc/hosts... it will work for you.

eli_revach
Forum|alt.badge.img+2
  • Participating Frequently
  • August 28, 2014
For localhost  singel node database , "-s localhost"   is not needed , do you try to run the create without the -s localhost   ?

Arvind_Kumar
Forum|alt.badge.img+1
  • Participating Frequently
  • August 28, 2014
I had the same issue for my single node,

i resolved it by putting correct ip and corresponding hostname in /etc/hosts
and it worked

Starting bootstrap node v_mvl_node0001 (127.0.0.1)
ERROR: Unable to read bootstrap node metadata

this is error happened because in /etc/hosts there is no entry for your machine ip and its hostname

do it and let me know....i will try to help

i believe correcting /etc/hosts will work for you.

Thanks

Aidan_yp
  • New Participant
  • August 29, 2014
I'm having the same error on a cluster of 3 nodes.  Any suggestions?

Arvind_Kumar
Forum|alt.badge.img+1
  • Participating Frequently
  • August 29, 2014
i will suggest to correct /etc/hosts file for all three nodes then install if you will get error even after doing this please share your /etc/hosts, i will try to dig it more.
But please make sure you have correct /etc/hosts file in your nodes.

Aidan_yp
  • New Participant
  • August 30, 2014
I do have /etc/hosts with the correct host ip and hostname associated with it but it's still not working.

Example from one of the 3 hosts:
10.3.70.219 vertica-dev1 vertica-dev1.domain.com


In /opt/vertica/log/adminTools-dbadmin.log 

Aug 29 20:33:14  [13331] <BashAdapter: vertica@10.3.70.219> (Bootstrapping database testdb): <command hidden> Aug 29 20:33:14  [13331] [SSH.createDBMultiNodes] cmd output '['0', ['License installed for companyx', '', 'Catalog succ
essfully bootstrapped']]' 
Aug 29 20:33:14  [13331] <BashAdapter: vertica@10.3.70.219> (Reading bootstrap catalog): <command hidden> 
Aug 29 20:33:15  [13331] Unable to read bootstrap node metadata.  Expected JSON DB desc, got: Traceback (most recent 
call last):
  File "/opt/vertica/oss/python/lib/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/opt/vertica/oss/python/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/opt/vertica/share/eggs/vertica/config/VDatabase.py", line 382, in <module>
    readAndOutputJSON(sys.argv[1], len(sys.argv) > 2 and sys.argv[2] == "silent")
  File "/opt/vertica/share/eggs/vertica/config/VDatabase.py", line 373, in readAndOutputJSON
    db.loadFromCatalog(ce)
  File "/opt/vertica/share/eggs/vertica/config/VDatabase.py", line 221, in loadFromCatalog
    self.name = ce.sendCmd("get singleton Database name").strip()
  File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/tools/CatalogEditor.py", line 72, in sendCmd
    self.ceproc.stdin.write(cmd+"\n")
IOError: [Errno 32] Broken pipe 
Aug 29 20:33:15  [13331]        Multi-node start returns: 0 


Aidan_yp
  • New Participant
  • August 30, 2014
I did a new install with Vertica on version 7.0 and the problem isn't there.

Andrew_Coons
  • New Participant
  • September 30, 2014
Hello Victor,

I had the same problem as you running on a similar setup. I had the same error in my log file and I eventually found the problem in another thread (https://community.vertica.com/vertica/topics/unable_to_read_bootstrap_node_metadata). I found that for some reason my dbadmin's open file limit was set too low (run ulimit -n or ulimit -a to check all limits on dbadmin), hope this helps, good luck!

-Andrew


Adam_1
Forum|alt.badge.img
  • Participating Frequently
  • November 20, 2014
Hello,

I have the following problem:
*** Creating database: test ***
            127.0.0.1 OK [vertica][(7, 1, 1)][000][all]
    Creating database test
ERROR: Unable to bootstrap database: Unable to clean up temp directory: Could not remove file [/initrd.img]: Permission denied
Press RETURN to continue

What does it mean?

Prasanta_Pal
Forum|alt.badge.img
  • Participating Frequently
  • November 20, 2014
Ii looks like a permission issue, if you know the directory where the file "initrd.img" is, please check if the dbadmin ( or the dba-user if you have different one) has the permission to read/write.
Check also the /tmp folder if dbadmin is able to write/read.


Adam_1
Forum|alt.badge.img
  • Participating Frequently
  • November 20, 2014
Hello Prasanta Pal,

Thank you for your answer. The initrd.img file is in "/" directory. I manually removed the file. Then the program wanted to remove vmlinuz file and I also removed this file manually, but it didn't help. Finally, I gave access to the /tmp directory to everybody, but the result was the same as previously.

I installed Vertica on a virtual machine (ubuntu 14 lts) and suppose that maybe a problem is with not sufficient resources or maybe I did not set a parameter. It was the second time when I installed Vertica. The previous installation worked (however it wasn't on a virtual machine).

Prasanta_Pal
Forum|alt.badge.img
  • Participating Frequently
  • November 21, 2014
Can you paste the admintools.conf file to review the details?
located in /opt/vertica/config folder



Adam_1
Forum|alt.badge.img
  • Participating Frequently
  • November 23, 2014
cat admintools.conf

[Configuration]
last_port = 5433
tmp_dir = /tmp
default_base = /home/dbadmin
format = 3
install_opts = -s localhost -d /home/dziedzic/cloud_store/databases/Vertica/data -g dziedzic -u dziedzic -p '*******'
spreadlog = False
controlsubnet = default
controlmode = broadcast

[Cluster]
hosts = 127.0.0.1

[Nodes]
node0001 = 127.0.0.1,/home/dziedzic/cloud_store/databases/Vertica/data,/home/dziedzic/cloud_store/databases/Vertica/data


Adam_1
Forum|alt.badge.img
  • Participating Frequently
  • December 4, 2014
Hello, the problem is that the configuration file: /etc/security/limits.conf was changed. Here is the solution: https://community.vertica.com/vertica/topics/not_enough_open_file_handles_allowed Basically, check if the command: ulimit -n gives you at least: 65536.

If not then change the configuaration file /etc/security/limits.conf Add a line: <user>   -    nofile    62363. It should work!





Ahmet_Fuat_Sung
  • Participating Frequently
  • October 14, 2015

When I encounter this problem I change my locale settings and then this error has gone. Please check your locale settings by issuing "locale" in command line. If it is not en_US.UTF-8 it may be the cause of your problem.

 

To change locale settings, issue these commands:

 

export LC_ALL=en_US.UTF-8

export LANG=en_US.UTF-8