Skip to main content

Unable to read bootstrap node metadata.

  • October 19, 2014
  • 6 replies
  • 25 views

Boris_Kochkaryo
Hi, I install vertica on ubuntu 12.04, but I can not create a database. Please help.
Log admintools

Oct 18 20:45:43 [1858] <------>Creating database. Oct 18 20:45:43 [1858] [SSH.createDBMultiNodes] bootstrapping with idx 0 node v_ert_node0001 on host 127.0.0.1. Oct 18 20:45:43 [1858] [SSH.createDBMultiNodes] bootstrap cmd '/opt/vertica/bin/bootstrap-catalog -C 'ert' -H '127.0.0.1' -s 'v_ert_node0001' -D '/db/vertica/ert/v_ert_node0001_catalog' -S '/db/vertica/er Oct 18 20:45:43 [1858] (Bootstrapping database ert): . Oct 18 20:45:43 [1858] [SSH.createDBMultiNodes] cmd output '['0', ['License installed for Vertica Community Edition ', '', 'Catalog successfully bootstrapped']]'. Oct 18 20:45:43 [1858] (Reading bootstrap catalog): . Oct 18 20:45:44 [1858] Unable to read bootstrap node metadata. Expected JSON DB desc, got: Stopping editor Error stopping editor: [Errno 3] No such process Traceback (most recent call last): File "/opt/vertica/oss/python/lib/python2.7/runpy.py", line 162, in _run_module_as_main "__main__", fname, loader, pkg_name) File "/opt/vertica/oss/python/lib/python2.7/runpy.py", line 72, in _run_code exec code in run_globals File "/opt/vertica/share/eggs/vertica/config/VDatabase.py", line 296, in readAndOutputJSON(sys.argv[1], len(sys.argv) > 2 and sys.argv[2] == "silent") File "/opt/vertica/share/eggs/vertica/config/VDatabase.py", line 288, in readAndOutputJSON db.loadFromCatalog(ce) File "/opt/vertica/share/eggs/vertica/config/VDatabase.py", line 136, in loadFromCatalog self.name = ce.sendCmd("get singleton Database name").strip() File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/tools/CatalogEditor.py", line 53, in sendCmd self.ceproc.stdin.write(cmd+"\n") IOError: [Errno 32] Broken pipe Exception OSError: (32, 'Broken pipe') in > ignored. Oct 18 20:45:44 [1858] <------>Multi-node start returns: 0. Oct 18 20:45:44 [1858] [killVerticaProcess] [ -e /db/vertica/ert/v_ert_node0001_catalog/vertica.pid ]. Oct 18 20:45:44 [1858] : ['[ -e /db/vertica/ert/v_ert_node0001_catalog/vertica.pid ]']. Oct 18 20:45:44 [1858] : (rc=1) [].

6 replies

R_McKeon
Forum|alt.badge.img
  • Participating Frequently
  • October 20, 2014
Hello Boris,

At your earliest convenience, please send in the output of the following command run on the Vertica node you're attempting to create the database on:

ulimit -u

Thanks,
Rory

Adam_1
Forum|alt.badge.img
  • Participating Frequently
  • November 18, 2014
Hi, I have the same problem. My ulimit -u command returns: 30429

Adam_1
Forum|alt.badge.img
  • Participating Frequently
  • November 18, 2014
Hi, I have the same problem. My ulimit -u returns 30429, so I suppose this value is sufficient for Vertica.

Artyom_Apalko
  • New Participant
  • December 6, 2014
Hi! I have the same problem too. 

This is my adminTools-dbadmin.log:
Dec  5 19:31:11  [1860] <BashAdapter: dbadmin@127.0.0.1>: (rc=255) ['Stopping editor', 'Error stopping editor: [Errno 3] No such process', 'Traceback (most recent call last):', '  File "/opt/vertica/oss/python/lib/python2.7/runpy.py", line 162, in _run_module_as_main', '    "__main__", fname, loader, pkg_name)', '  File "/opt/vertica/oss/python/lib/python2.7/runpy.py", line 72, in _run_code', '    exec code in run_globals', '  File "/opt/vertica/share/eggs/vertica/config/VDatabase.py", line 382, in <module>', '    readAndOutputJSON(sys.argv[1], len(sys.argv) > 2 and sys.argv[2] == "silent")', '  File "/opt/vertica/share/eggs/vertica/config/VDatabase.py", line 373, in readAndOutputJSON', '    db.loadFromCatalog(ce)', '  File "/opt/vertica/share/eggs/vertica/config/VDatabase.py", line 221, in loadFromCatalog', '    self.name = ce.sendCmd("get singleton Database name").strip()', '  File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/tools/CatalogEditor.py", line 72, in sendCmd', '    self.ceproc.stdin.write(cmd+"\\n")', 'IOError: [Errno 32] Broken pipe']Dec  5 19:31:11  [1860] Unable to read bootstrap node metadata.  Expected JSON DB desc, got: Stopping editor
Error stopping editor: [Errno 3] No such process
Traceback (most recent call last):
  File "/opt/vertica/oss/python/lib/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/opt/vertica/oss/python/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/opt/vertica/share/eggs/vertica/config/VDatabase.py", line 382, in <module>
    readAndOutputJSON(sys.argv[1], len(sys.argv) > 2 and sys.argv[2] == "silent")
  File "/opt/vertica/share/eggs/vertica/config/VDatabase.py", line 373, in readAndOutputJSON
    db.loadFromCatalog(ce)
  File "/opt/vertica/share/eggs/vertica/config/VDatabase.py", line 221, in loadFromCatalog
    self.name = ce.sendCmd("get singleton Database name").strip()
  File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/tools/CatalogEditor.py", line 72, in sendCmd
    self.ceproc.stdin.write(cmd+"\n")
IOError: [Errno 32] Broken pipe

admintools.conf:
[Configuration]
last_port = 5433
tmp_dir = /tmp
default_base = /home/dbadmin
format = 3
install_opts = --hosts localhost --failure-threshold FAIL
spreadlog = False
controlsubnet = default
controlmode = broadcast

[Cluster]
hosts = 127.0.0.1

[Nodes]
node0001 = 127.0.0.1,/home/dbadmin,/home/dbadmin

ulimit -n returns 65536. 


Amir_Tuval
Forum|alt.badge.img
  • Participating Frequently
  • February 5, 2015
If anyone's interested, I had the exact same issue.

In my case, it was a locale configuration issue, which prevented the vertica binary from successfully starting.

To see if you have this issue, run the following command

locale

If you see warnings or errors, you have to fix them.

Once I did, the issue went away.

Hope this helps
Amir

Forum|alt.badge.img+2
  • Participating Frequently
  • April 24, 2015

If your error message starts with something like below:

Apr 21 19:49:59  [45008] Unable to read bootstrap node metadata.  Expected JSON DB desc, got: Stopping editor Error stopping editor: [Errno 3] No such process

 

The error text regarding "Error stopping editor: [Errno 3] No such process" implies that the script couldn't launch a vertica process with special args to try to load and read the catalog created by an earlier boostrap routine. One potential root cause is open file limit. If the open file limit (ulimit -n, ulimit -Hn, ulimit -Sn) are too low vertica won't start. In the situation I ran into they were set to 16k and customer bumped it to 32k and then the create worked.

 

You can test this by cd to the catalog dir and executing vertica from the command line, noting the documented recommendation is 65536 or mb of memory, whichever is highest.
[dbadmin@scrossman6 v_af_node0001_catalog]$ /opt/vertica/bin/vertica -D .
ERROR: Host does not meet minimum requirements:
Not enough open file handles allowed (16192 available/32768 required); see 'ulimit -n'.

 

Hoppe it helps,

Steve (I work for HP)