Skip to main content
Question

Unable to read database catalogs - cannot start database.

  • January 16, 2020
  • 2 replies
  • 12 views

manojprabhat09

We are using the vertica db, but last two days we are the getting the following message when we tried to start the database. Please suggest how can we resolve this issue ASAP .

2 replies

mosheg
Forum|alt.badge.img+2
  • Participating Frequently
  • January 16, 2020
  1. Does the catalog directory accessible to Vertica on all nodes?
  2. Is it mounted as it should? (Try to mount again the volume)
  3. Does the catalog dir path is owned by dbadmin (or your Vertica super user) on all nodes?
  4. What is the message you get in vertica.log after /opt/vertica/bin/admintools -t start_db -d -F
    tail -f catalog-path/database-name/node-name_catalog/vertica.log
  5. If database fails to start before it can write messages into vertica.log check
    catalog-path/database-name/dbLog
    ** /opt/vertica/log/adminTools.log**
    /opt/vertica/log/adminTools.errors
  6. If the problem persists please open a support ticket.

fakhfaakh
  • New Participant
  • November 20, 2020

Run the following command :
ssh IP address of the node
I had the same issue and this worked for me.