Skip to main content

Unable to start database or create a new database

  • March 2, 2016
  • 6 replies
  • 23 views

Hari_rao
Forum|alt.badge.img+1

Recently a server of our's went down because of power outage at remote server location. We have Vertica CE installed there which was working perfectly fine until the abrupt shutdown. Since then we are unable to start the vertica process and thus we are unable to start the databases. When we start vertica under dbadmin using

 

$ /etc/init.d/verticad start

 

We get Start OK for users dbadmin  but when we check the status, it says vertica did not start at all. We are unable to find the reason behind the issue. Could anyone guide us on this.

 

 

6 replies

sKwa
Forum|alt.badge.img+1
  • Participating Frequently
  • March 2, 2016

Hari_rao
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • March 2, 2016

Hi sKwa !

I know verticad is not the dbms. And I also understand how to start the database inside adminTools  or by  /opt/vertica/bin/admintools --tool start_db [ options ]

 

The problem I'm facing is the application itself is not coming up. vertica has to be running to start any database, right. So I'm unable to start vertica itself.

 

just as a try with the shell command to start a database, I tried 

/opt/vertica/bin/admintools --tool start_db -d mydatabase -p passwd 

and I got the error:

 

Unable to read database catalogs - cannot start database.
Database mydatabase did not start successfully.

 

The main problem is here:-

$ /etc/init.d/verticad start
   Vertica: Password:
   start OK for users: dbadmin

$ ps -ef | grep vertica

$ dbadmin  13161 16990  0 18:19 pts/0    00:00:00 grep vertica

 

The vertica service/ process itself is not starting.


Adrian_Oprea_1
Forum|alt.badge.img+1
  • Participating Frequently
  • March 2, 2016

Hi, 

Did you alter anything in your Linuc limits.conf file ?

 

Is the dbadmin user configurated with unlimited resources at the OS level ?

 

 

 try to run the following:

/opt/vertica/bin/admintools --tool start_db -d mydatabase -p passwd -f

If not try to run the following:

echo -e "listdetails Site" |/opt/vertica/bin/vertica -D /path to the/catalog/dbname/v_dbname_nodename_catalog/ -E'batch'

 post the output here 


Renjith_Alex
  • New Participant
  • March 3, 2016

I got like as follows 

 

vertica@lnxapp103:/home> echo -e "listdetails Site" |/opt/vertica/bin/vertica -D /apps/vertica/catalog/PHIDB/v_phidb_node0001_catalog/  -E'batch'

/opt/vertica/bin/vertica: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /opt/vertica/bin/vertica)


Renjith_Alex
  • New Participant
  • March 3, 2016

The background is like as follows .

 

we upgraded the the DB from 7.0 to 7.2 directly .Upgrade completed successfully .But not able to start the database using admintools .

 

vertica@lnxapp103:/apps/vertica/catalog/PHIDB/v_phidb_node0001_catalog> /opt/vertica/bin/admintools --tool start_db -d PHIDB -p BDVh3STe

Unable to read database catalogs - cannot start database.

Database PHIDB did not start successfully

vertica@lnxapp103:/apps/vertica/catalog/PHIDB/v_phidb_node0001_catalog> cd /home/

vertica@lnxapp103:/home> pwd

/home

vertica@lnxapp103:/home> echo -e "listdetails Site" |/opt/vertica/bin/vertica -D /apps/vertica/catalog/PHIDB/v_phidb_node0001_catalog/  -E'batch'

/opt/vertica/bin/vertica: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /opt/vertica/bin/vertica)

 

Please advise is this problem with direct upgrade from 7.0 to 7.2 ? is there is any solution on this?

 

Thanks

Renjith Alex


Adrian_Oprea_1
Forum|alt.badge.img+1
  • Participating Frequently
  • March 3, 2016

DUPLICATE POST !  

 

I think you are missing gcc ! 

Also the upgrade path clearly states that is from 7.0 --> 7.1 --> 7.2 , you might of missed some libs in the process.

 

Install gcc, this will also install the libstdc++.so.6.

 

After this try to start the database.

 Also make sure all path variables are avaialbe and set.