Skip to main content

Vertica 7.1 VM : Not being able to use MC or trying to take back up

  • December 18, 2014
  • 3 replies
  • 17 views

schowdh
Hi,

I installed vertica 7.1.1 virtual machine on my VMWare. The installation apparently working fine. I can follow the basic examples like creating a database (VMart), getting some data from it etc. But to experiment with MC, I installed the same vertica-console-7.1.1.0]

[dbadmin@vertica Desktop]$ rpm -qa | grep vertica
vertica-7.1.1-0
vertica-console-7.1.1-0

Now, when I am trying to access the console with the port it specified:
https://vertica:5450/webui
I get a time out error. The Firewall is disabled in the VM. So I can not access MC.

Now coming to problem 2, when I try to do the back up example, the back up fails as it can not connect to host.


[dbadmin@vertica Desktop]$ vbr.py --task backup --config-file exampleBackup.iniPreparing...
Found Database port:  5433
ssh: connect to host 192.168.1.1 port 22: Connection timed out
Unable to ssh to host: 192.168.1.1
backup failed!

Firewall is anyway not running, I checked /etc/init.d/sshd service is running. I tried vsql -l followed by echo $?, the result looks good [Refered to https://community.vertica.com/vertica/topics/how_to_tell_if_vertica_is_ready_to_accept_connections] Entries in

/etc/hosts file looks legitimate.
127.0.0.1               localhost.localdomain localhost::1             localhost6.localdomain6 localhost6
192.168.1.1             vertica

I tried to go refer https://community.vertica.com/vertica/topics/unable-to-create-first-database-in-vertica-on-centos , but not sure if I have same problem here.

Can anyone please let me know what is the issue I have here. Am I missing anything very basic?

Note: I work behind proxy, is that has anything to do?
Thanks.


3 replies

Raul_1
Forum|alt.badge.img
  • Participating Frequently
  • December 18, 2014
Can you include the output to the following -

cat /opt/vertica/config/admintools.conf
ifconfig -a
cat exampleBackup.ini
ping 192.168.1.1 (from the browser workstation)

You may have used the localhost IP.

schowdh
  • Author
  • New Participant
  • December 19, 2014
Please read
[dbadmin@vertica Desktop]$ cat /opt/vertica/config/admintools.conf
[Configuration]
.
.

as

 
[dbadmin@vertica Desktop]$ cat /opt/vertica/config/admintools.conf

[Configuration]
.
.


I tried to edit it but somehow the edit is not working. Apologies.

schowdh
  • Author
  • New Participant
  • December 19, 2014
Awesome!.. Thanks... Couple of points I additionally needed to do are
  1. In exampleBackup.ini I need to give complete path for the password file. Though I was running the vbr.py from the directory where the password file is located it was complaining it is not finding it.
  2. The firefox version came with CentOS Vertica VM is outdated and MC is thus not working properly. I tried to upgrade, that seems not working. Anyway, I used my windows box/chrome to communicate to the address:port, works fine.