Skip to main content

Vertica 9 not handling permanent redirects on s3.

  • October 30, 2017
  • 3 replies
  • 16 views

Bharath_Anandar

Hello -

Creating a cluster in EON mode fails with "Unable to parse ExceptionName: PermanentRedirect Message: The bucket you are attempting to access must be addressed using the specified endpoint. Please send all future requests to this endpoint."

We got the same error when trying to query a parquet file after upgrading to vertica 9 enterprise mode.

Case 00071999 has more details. The instances and the s3 bucket are in the same region.

-Bharath

3 replies

dsprogis
Forum|alt.badge.img
  • Participating Frequently
  • October 30, 2017

Bharath,

Check this documentation about the s3- naming and usage: http://docs.aws.amazon.com/AmazonS3/latest/dev/UsingBucket.html

While s3 buckets appear to be globally accessible in once sense, there must be some kind of routing requirement that seems to be addressed in the URL.

Dave


Bharath_Anandar
  • Author
  • New Participant
  • October 30, 2017

David -
I tried pretty much everything on that website on Friday. I'll give it a shot again, but I have my doubts.

-Bharath


Bharath_Anandar
  • Author
  • New Participant
  • October 31, 2017

Seems like we had to change the default aws region to our region and re install the awslib package. Looks like its working now.

Thanks
-Bharath