Skip to main content

Vertica agent not found on Centos 7.2

  • January 6, 2016
  • 5 replies
  • 28 views

MattK_1

After a clean install of both CentOS 7.2 and Vertica 7.2, vertica_agent cannot start, and this apparently keeps the MC from being able to connect:

 

    $ sudo /etc/init.d/vertica_agent status
    Vertica Agent: ● vertica_agent.service Loaded: not-found (Reason: No such file or directory) Active: inactive (dead)

 

5 replies

MattK_1
  • Author
  • New Participant
  • January 6, 2016
# /etc/init.d/vertica_agent enable
# [ OK ]

# /etc/init.d/vertica_agent start
Reloading systemd: [ OK ]
Starting vertica_agent (via systemctl): Failed to start vertica_agent.service: Unit vertica_agent.service failed to load: No such file or directory.
[FAILED]

# /etc/init.d/vertica_agent status
use_agent=true
true
Vertica Agent: ● vertica_agent.service Loaded: not-found (Reason: No such file or directory) Active: inactive (dead)

 

$ ps -ef | grep vertica
dbadmin 10521 1 0 23:34 pts/1 00:00:00 /opt/vertica/spread/sbin/spread -c /localdata/vertica/hwdw/v_hwdw_node0001_catalog/spread.conf -D /opt/vertica/spread/tmp
dbadmin 10523 1 12 23:34 ? 00:00:11 /opt/vertica/bin/vertica -D /localdata/vertica/hwdw/v_hwdw_node0001_catalog -C hwdw -n v_hwdw_node0001 -h 192.168.17.4 -p 5433 -P 4803 -Y ipv4
dbadmin 10527 10523 0 23:34 ? 00:00:00 /opt/vertica/bin/vertica-udx-zygote 16 3 10523 debug-log-off /localdata/vertica/hwdw/v_hwdw_node0001_catalog/UDxLogs 60 17

 


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • January 7, 2016

HI,

 

   Please use the command 

 

sudo /opt/vertica/sbin/vertica_agent start

 

to start vertica_agent. 

 

Thank you,

Sruthi


MattK_1
  • Author
  • New Participant
  • January 7, 2016

That worked, I will have to make sure that the service can start on boot as well.

 


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • January 7, 2016

Hi,

 

    Yes. That will be perfect.

 

Sruthi


KaiPingLi
  • New Participant
  • April 8, 2016

I use "/opt/vertica/sbin/vertica_agent start " successful 

But ...

How to "auto" start vertica_agent when I reboot Linux ?

And ...

How to "auto" start my database when I reboot ??

 

Thanks to help me please ^_^