Skip to main content

Vertica Backup Failed due to SSH

  • August 8, 2019
  • 1 reply
  • 7 views

Hi Vertica Forum,

I was able to backup our Vertica DB last July 26.

But unfortunately we have configured the passwordless authentication in our vertica server for some purpose.

As of now, backup script is failing. I don't have any clues how can I fix this error now.

Error: Unable to connect to backup host via password-less SSH: dmdb. Permission denied (publickey,password).

Init FAILED.

Thanks,
Ervin

1 reply

praveshbhardwaj
Forum|alt.badge.img+1
  • Participating Frequently
  • August 8, 2019
Vertica backup utility requires passwordless SSH (for database admin user) between Database cluster hosts and backup hosts.

I would try reconfiguring passwordless SSH.
Given below is relevant section from Vertica 9.2 documentation.

https://www.vertica.com/docs/9.2.x/HTML/Content/Authoring/AdministratorsGuide/BackupRestore/ConfiguringBackupHosts.htm

Thanks