Skip to main content

Vertica cannot be started with verticad command after EncryptSpreadComm parameter is set

  • August 25, 2021
  • 1 reply
  • 3 views

raulk89
Forum|alt.badge.img+2

Hi

Vertica 10 and 11. Single node database.

Why is it that, after I have set EncryptSpreadComm parameter:
ALTER DATABASE mydb SET PARAMETER EncryptSpreadComm = 'vertica';

I cannot start my database anymore with the following command:
/opt/vertica/sbin/verticad start

For example, when EncryptSpreadComm parameter was set, I did stop/start database first with admintools commands, since this parameter does not take effect until database restart.

admintools -t stop_db -d mydb
admintools -t start_db -d mydb

This parameter EncryptSpreadComm indeed is set now:

dbadmin=> show current EncryptSpreadComm;
level | name | setting
----------+-------------------+---------
DATABASE | EncryptSpreadComm | vertica
(1 row)

dbadmin=> SELECT SECURITY_CONFIG_CHECK('NETWORK');

Spread security details:
EncryptSpreadComm = [vertica]
Spread encryption is enabled
It is now safe to set/change other security knobs
..........

Now I stop it again with admintools command:
admintools -t stop_db -d mydb
And try to start with verticad command:
/opt/vertica/sbin/verticad start

And this log file "/opt/vertica/log/verticad.log" has the following message:

Considering command 'start' for database mydb
failed to fetch one upnode from DBState
starting DB: mydb
Restarting host [192.168.10.101] with catalog [v_mydb_node0001_catalog]
Failed to start database mydb, message: 'Restart failed. It seems that the EncryptSpreadComm config parameter was changed but the database was not restarted. To fix this, either restart the database (which fully enforces the parameter) or revert the parameter to its earlier value, and try restarting the node(s) again.'

And database does not start.

In contrast, when I clear EncryptSpreadComm parameter: ALTER DATABASE mydb CLEAR EncryptSpreadComm;

And bounce the database (for this to take effect) and stop it again.

Then I can start it with verticad command just fine:

Considering command 'start' for database mydb
failed to fetch one upnode from DBState
starting DB: mydb
Restarting host [192.168.10.101] with catalog [v_mydb_node0001_catalog]
Issuing multi-node restart
Starting nodes:
v_mydb_node0001 (192.168.10.101)
Starting Vertica on all nodes. Please wait, databases with a large catalog may take a while to initialize.
Node Status: v_mydb_node0001: (DOWN)
Node Status: v_mydb_node0001: (DOWN)
Node Status: v_mydb_node0001: (DOWN)
Node Status: v_mydb_node0001: (DOWN)
Node Status: v_mydb_node0001: (UP)
Successfully started mydb

Also, if anyone could explain, what does this message mean and is there something that can be done to get rid of it ..?

failed to fetch one upnode from DBState

Regards
Raul

1 reply

raulk89
Forum|alt.badge.img+2
  • Author
  • Participating Frequently
  • November 19, 2021

Issue still present in 11.0.1

Hasn't anyone noticed this issue..?

Regards
Raul