Hi everyone,
We have a problem with data integration. We are trying to put data to Vertica from MS SQL by using SAP DataServices, but we are getting an error(I shared in below) and whenever we try to change data types to varchar(255), we can handle that error.
We tried to change Vertica's collation but it didn't work. Before that we were seeing special characters(ş, ç eg.) as special icons like '?' or 'triangle' in SAP DataServices preview, we changed ODBC connection settings to handle that problem and it worked but still, we are getting an error if don't change default varchar values to 255.
Is there any known solution for this error?
Error
Possible causes: (1) Error in the SQL
syntax; (2) Database connection is broken; (3) Database related errors such as transaction log is full, etc.; (4) The user
defined in the datastore has insufficient privileges to execute the SQL. If the error is for preload or postload operation, or
if it is for regular load operation and load triggers are defined, check the SQL. Otherwise, for (3) and (4), contact your
local DBA
Thank you.

