We recently moved vertica database from a CentOS server to Ubuntu server. We encountered an issue while configuring the Vertica Management Console after that. After completing the basic configurations, the page became stuck in a loop. Upon reviewing the logs, we found the following warning from KeycloakDeployment: "Failed to load URLs. Connection to 20.232.43.37:5450 failed: Connection timed out."
The logs further indicate an error while attempting to load URLs from https://ipaddress:5450/auth/realms/vertica/.well-known/openid-configuration, resulting in a connection timeout.
31 Jul 2024 11:20:47,813 [qtp1297149880-15] KeycloakDeployment WARN - Failed to load URLs from https://ipaddress:5450/auth/realms/vertica/.well-known/openid-configuration
org.apache.http.conn.HttpHostConnectException: Connect to ipaddress:5450 [/ipadress] failed: Connection timed out (Connection timed out)
at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:156) ~[httpclient-4.5.13.jar:4.5.13]
at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.connect(PoolingHttpClientConnectionManager.java:376) ~[httpclient-4.5.13.jar:4.5.13]
ipaddress stands for our vertica VM ip. Any help on this is appreciated.