Skip to main content

Vertica: Copy cluster Fail version 7.2.1

  • February 17, 2016
  • 11 replies
  • 35 views

Peacherr
Forum|alt.badge.img+1

         I have 2 cluster and 3 node per cluster.

 

I try to set up copy cluster and run command

/opt/vertica/bin/vbr.py -t copycluster --config-file /home/dbadmin/backup_script/copy_cluster.ini

 

 

found message:

Configured backup directories in Mapping are ignored for copycluster.
Starting copy of database xxxxx_DW.
Participating nodes: v_xxxxx_dw_node0001, v_xxxxx_dw_node0002, v_xxxxx_dw_node0003.
Snapshotting database.
Snapshot complete.
Syncing data to destination cluster.
[==================================================] 100%
Reinitializing destination catalog.
Error: Catalog bootstrap failed.
Copycluster FAILED.

 

 

 

 how to resolve this problem? How can I solve it?

 

 

11 replies

SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 17, 2016

Hi,

 

   Can you share me the .ini file used for copy cluster and also the vertica.log located in catalog directory of the source cluster.

 

 

Thank you,

 Sruthi


Peacherr
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • February 18, 2016

hi,

       Thanks for your help . Here is the config file and log

 

snapshotName = full_backup
restorePointLimit = 4
tempDir = /tmp/vbr_rsyncd
retryCount = 2
retryDelay = 1

[Database]
dbName = xxxxx_DW
dbUser = dbadmin
dbPassword = dbadmin1
dbPromptForPassword = False

[Transmission]
encrypt = False
checksum = False
port_rsync = 50000


[Mapping]
v_xxxxx_dw_node0001= bk-vtgpoc-1101:/backup
v_xxxxx_dw_node0002= bk-vtgpoc-1102:/backup
v_xxxxx_dw_node0003= bk-vtgpoc-1103:/backup


Peacherr
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • February 18, 2016

Here is the log

 

thanks


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 18, 2016

Hi,

 

 

       Vertica.log shared to me contains log from 2016-02-16 22:20:07.077.I could not find any instance of copycluster in the log. Did you run copylcuster before that time? If so could please run it now and share me the log. Please map the node names with IP addresses instead of host names in .ini file and then give a try. Are source and target cluster on 7.2.1??

 


2016-02-16 22:20:07.077 INFO New log
2016-02-16 22:20:07.077 unknown:0x7f0ce100a720 [Init] <INFO> Log /agoda/Agoda_DW/Agoda_DW/v_agoda_dw_node0001_catalog/vertica.log opened; #1
2016-02-16 22:20:07.077 unknown:0x7f0ce100a720 [Init] <INFO> Processing command line: /opt/vertica/bin/vertica -D /agoda/Agoda_DW/Agoda_DW/v_agoda_dw_node0001_catalog -C Agoda_DW -n v_agoda_dw_node0001 -h 192.168.6.1 -p 5433 -P 4803 -Y ipv4
2016-02-16 22:20:07.077 unknown:0x7f0ce100a720 [Init] <INFO> Starting up Vertica Analytic Database v7.2.1-0
2016-02-16 22:20:07.077 unknown:0x7f0ce100a720 [Init] <INFO> Project Codename: Excavator
2016-02-16 22:20:07.077 unknown:0x7f0ce100a720 [Init] <INFO> vertica(v7.2.1-0) built by jeeves@build-centos6 from releases/VER_7_2_RELEASE_BUILD_1_0_20151116@177918 on 'Mon Nov 16 16:59:07 2015' $BuildId$
2016-02-16 22:20:07.077 unkno


Peacherr
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • February 18, 2016

hi 

   Thanks for your suggestion. I try to change the .ini file using io-address instead of host name and rerun copy cluster process again. source and dest cluster is version 7.2.1

It shows the message:

 

[dbadmin@bk-vtgpoc-1001 agoda]$ /opt/vertica/bin/vbr.py -t copycluster --config- file /home/dbadmin/backup_script/copy_cluster.ini
Configured backup directories in Mapping are ignored for copycluster.
Starting copy of database Agoda_DW.
Participating nodes: v_agoda_dw_node0001, v_agoda_dw_node0002, v_agoda_dw_node0003.
Snapshotting database.
Snapshot complete.
Syncing data to destination cluster.
[==================================================] 100%
Reinitializing destination catalog.
While bootstrapping catalog: Errors found in SAL or Catalog, check log for details.

While bootstrapping catalog: Errors found in SAL or Catalog, check log for details.

While bootstrapping catalog: Errors found in SAL or Catalog, check log for details.

Error: Catalog bootstrap failed.
Copycluster FAILED.


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 18, 2016

Hi,

 

   Can you send me the output of the folllowing



 From source DB
 for host in <list comma seperated ip address>; do ssh $host " find /export/vertica_data1/WH
 -name globalsequence.cat -exec cat {} \; " ; done

 From target DB
 for host in<list comma seperated ip address>; do
 ssh $host " find /export/vertica_data1/WH -name globalsequence.cat -exec
cat {} \; " ; done

 

 

Sruthi


Peacherr
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • February 19, 2016

Hi 

       Here is the result :

 

Source:

[dbadmin@bk-vtgpoc-1001 ~]$ for host in 10.120.3.134 10.120.3.135 10.120.3.136; do ssh $host " find /export/vertica_data1/WH -name globalsequence.cat -exec cat {} \; " ; done
find: `/export/vertica_data1/WH': No such file or directory
find: `/export/vertica_data1/WH': No such file or directory
find: `/export/vertica_data1/WH': No such file or directory

 

Destination

for host in 10.120.1.131 10.120.1.132 10.120.1.133; do ssh $host " find /export/vertica_data1/WH -name globalsequence.cat -exec cat {} \; " ; done
find: `/export/vertica_data1/WH': No such file or directory
CentOS release 6.5 (Final)
Kernel 2.6.32-431.el6.x86_64 on an x86_64

find: `/export/vertica_data1/WH': No such file or directory
CentOS release 6.5 (Final)
Kernel 2.6.32-431.el6.x86_64 on an x86_64

find: `/export/vertica_data1/WH': No such file or directory

 


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 21, 2016

Hi,

 

 

        Is the vertica version same on both clusters?

 

 

Thank you,

 Sruthi


Peacherr
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • February 22, 2016

same version. ^^


Gayatri_R
Forum|alt.badge.img
  • Participating Frequently
  • February 22, 2016

Hi,

 

Looking at the bootstrap-catalog.log, I suspect some file corruption on the target database.

 

Is this something you can try

1. Drop the target database.

2. Create a new db that meets all the copycluster requirements.

3. Shutdown the target db.

4. Try copycluster from the source.

 

Thanks

Gayatri

 

 


Peacherr
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • February 23, 2016

Hi ,

 

       -  I try to  set up that you recommend . It still fail and show message error about bootstrap fail.

       -  I try to copy vbr.py file version 7.1 (vbr file from another server not involve testing cluster) and replace it on  same location.

          then run  /opt/vertica/bin/vbr.py -t copycluster --config-file /home/dbadmin/backup_script/copy_cluster.ini

          It shows :

Copying...
[==================================================] 100%
All child processes terminated successfully.
copycluster done!

          after check the data on destination, data updated

   

   I'm not sure that It is the bug of vbr.py script version 7.2 or not !!

 

thanks