Skip to main content

Vertica Database is not getting started

  • May 24, 2017
  • 3 replies
  • 14 views

sathyendra

Hi all,
We have Vertica database installed on RHEL 6.7 (Single Standalone server)
Now for some unknown reasons, the vertica server got rebooted (server team is investigating the root cause) and Vertica database is not getting started.
Tried to start from AdminTools --> No luck.
Tried to restore last healthy epoch point --> No luck
Below is the error message it gives:

Node status: v_pmdb_node0001: (DOWN)
Error starting database, no nodes are up

Please help me with this.

Thanks and Regards,
Sathyendra

3 replies

Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • June 16, 2017

You may be able to start an ornery DB using the start_db option of the admintools command line utility in conjunction with the -F, --force option. This will force the database to start at an epoch before data consistency problems were detected.

See:
https://my.vertica.com/docs/8.1.x/HTML/index.htm#Authoring/AdministratorsGuide/OperatingTheDatabase/StartingTheDatabase.htm


Car1os
Forum|alt.badge.img
  • Participating Frequently
  • June 16, 2017

Look at the vertica.log to get more information.


Jim_Knicely
Forum|alt.badge.img+2
  • Participating Frequently
  • June 16, 2017

You can also check the /opt/vertica/log/adminTools.log and the dbLog files for information.