Skip to main content

Vertica database will not start if LDAPLink parameters consist of special char, for example "ü"

  • January 23, 2023
  • 10 replies
  • 6 views

raulk89
Forum|alt.badge.img+2

Vertica 12.0.2

If you have LDAPLink set up the way that those parameter Distinguished Name consist of special chars, for example "ü" (also "ä", "ö", "õ", ..), then your database will not start !

LDAPLinkFilterGroup
LDAPLinkFilterUser

When I try to start it

su - dbadmin -c "admintools -t start_db -d xxxxdb"
Info: no password specified, using none
Going with traditional slower startup
Spread encryption is enabled. Key rotation will be performed.

  • Database config synchronization step failed. Please check logs *
    Database xxxxdb did not start successfully: Unable to synchronize database config on all nodes..
    Hint: if you use Eon mode, then you may need to start all primary nodes.

admintools.log file is following:

2023-01-06 16:51:29.703 admintools/3870:0x7fd978c37740 [ATFileCopy._copyPathImpl] Copy Failed on x.x.x.x: status=Failure host=x.x.x.x version=vertica.engine.api.at_send_file/1.0.0 content={"runner_ack": true} error_message=file length mismatch 10064 does not match source: 10071
2023-01-06 16:51:29.703 admintools/3870:0x7fd978c37740 [adminExec.synchronizeDatabaseConfig] [synchronize vertica.conf] failure to send to host x.x.x.x
2023-01-06 16:51:29.703 admintools/3870:0x7fd978c37740 [adminExec.dbStart] * Database config synchronization step failed. Please check logs *
2023-01-06 16:51:29.703 admintools/3870:0x7fd978c37740 [commandLineCtrl.startDB] Database xxxxdb did not start successfully: Unable to synchronize database config on all nodes..
Hint: if you use Eon mode, then you may need to start all primary nodes.

Note that. Seems like it is some kind of multibyte char bug. So this length function does not seem to take into account that there may not be only single byte chars.

error_message=file length mismatch 10064 does not match source: 10071

I modified file: /var/lib/vertica/xxxxdb/v_xxxxdb_node0001_catalog/vertica.conf
And removed these two parameters:

LDAPLinkFilterGroup=...
LDAPLinkFilterUser=...

Now database starts fine. And these same rows, that I removed from vertica.conf file, are returned there back.
So if I restart database again, I will get same error.

Raul

10 replies

VValdar
Forum|alt.badge.img+1
  • Participating Frequently
  • January 23, 2023

Hi Raul,
This looks like a bug, can you open a support ticket?


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • January 23, 2023

This is a known issue. it has been fixed in 12.0.3. Please upgrade your cluster. If you need more details on the bug, please open a support case.


Sergey_Cherepan_1
Forum|alt.badge.img+2

Is v 12.0.3 already out?


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • January 23, 2023

raulk89
Forum|alt.badge.img+2
  • Author
  • Participating Frequently
  • January 24, 2023

I did open SR - this SR has been idle'ing for almost 2 weeks with nothing helpful.

I reported this bug:
Date/Time Opened
06/1/2023, 15:50

I am telling you, I am getting better feedback from vertica forum posts than from vertica support.
Last useful info I get from support was this: They opened this for DEV team JIRA ID for reference is VER-85092.
And nothing more. Now from this forum post I see that there is a fix - which is not mentioned at all on vertica support.

Raul


raulk89
Forum|alt.badge.img+2
  • Author
  • Participating Frequently
  • January 24, 2023

It is not fixed !
Why would you misconfuse people like that ???

I just upgraded, I get same error

rpm -qa | grep vertica
vertica-12.0.3-0.x86_64

su - dbadmin -c "/opt/vertica/bin/admintools -t start_db -d xxxxdb"
Info: no password specified, using none
Going with traditional slower startup
Spread encryption is enabled. Key rotation will be performed.

  • Database config synchronization step failed. Please check logs *
    Database xxxxdb did not start successfully: Unable to synchronize database config on all nodes..
    Hint: if you use Eon mode, then you may need to start all primary nodes.

admintools.log

**2023-01-24 10:08:46.914 admintools/3689991:0x7f8155143740 [ATFileCopy._copyPathImpl] Copy Failed on x.x.x.x: status=Failure host=x.x.x.x version=vertica.engine.api.at_send_file/1.0.0 content={"runner_ack": true} error_message=file length mismatch 10221 does not match source: 10228

I AGAIN modified vertica.conf file and removed those 2 parameters.

vi /var/lib/vertica/xxxxdb/v_xxxxdb_node0001_catalog/vertica.conf

And it starts up.

su - dbadmin -c "/opt/vertica/bin/admintools -t start_db -d xxxxdb"
Info: no password specified, using none
Going with traditional slower startup
Spread encryption is enabled. Key rotation will be performed.
Starting nodes:
v_xxxxdb_node0001 (x.x.x.x)
Starting Vertica on all nodes. Please wait, databases with a large catalog may take a while to initialize.
Node Status: v_xxxxdb_node0001: (DOWN)
Node Status: v_xxxxdb_node0001: (DOWN)
Node Status: v_xxxxdb_node0001: (DOWN)
Node Status: v_xxxxdb_node0001: (DOWN)
Node Status: v_xxxxdb_node0001: (UP)

    Vertica version upgrade detected. Running upgrade tasks.

Creating procedures directory if it doesn't already exist
Running upgrade hooks
Upgrading (reinstalling) ComplexTypes package
Success: package ComplexTypes installed
Upgrading (reinstalling) DelimitedExport package
Success: package DelimitedExport installed
Upgrading (reinstalling) MachineLearning package
Success: package MachineLearning installed
Upgrading (reinstalling) OrcExport package
Success: package OrcExport installed
Upgrading (reinstalling) ParquetExport package
Success: package ParquetExport installed
Upgrading (reinstalling) VFunctions package
Success: package VFunctions installed
Upgrading (reinstalling) approximate package
Success: package approximate installed
Upgrading (reinstalling) flextable package
Success: package flextable installed
Upgrading (reinstalling) kafka package
Success: package kafka installed
Upgrading (reinstalling) logsearch package
Success: package logsearch installed
Upgrading (reinstalling) place package
Success: package place installed
Upgrading (reinstalling) txtindex package
Success: package txtindex installed
Upgrading (reinstalling) voltagesecure package
Success: package voltagesecure installed
Upgrading (reinstalling) JsonExport package
Success: package JsonExport installed
Database xxxxdb: Startup Succeeded. All Nodes are UP

Raul


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • January 24, 2023

@raulk89 I am sorry for the inconvenience caused. As per the JIRA, it contains the fix when Japanese/chinese/special characters such as 'ü' are present. It looks like you are still getting the issue after upgrade. please open support case and we can get more details and file a bug accordingly

VER-85092
LDAPLinkFilterGroup and LDAPLinkFilterUser containing multibyte chars preventing db from starting


raulk89
Forum|alt.badge.img+2
  • Author
  • Participating Frequently
  • January 24, 2023

I have SR opened up since 6. of January
No new updates for that SR.

Raul


raulk89
Forum|alt.badge.img+2
  • Author
  • Participating Frequently
  • January 24, 2023

And by the way, "ü" is the only special character for me, when I remove it from all the places, database will start up.

So "ü" is very much still the issue for me.

ü - "uuml;"

Raul


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • January 24, 2023

thank you @raulk89 . we will communicate via SR.