Vertica 12.0.2
If you have LDAPLink set up the way that those parameter Distinguished Name consist of special chars, for example "ü" (also "ä", "ö", "õ", ..), then your database will not start !
LDAPLinkFilterGroup
LDAPLinkFilterUser
When I try to start it
su - dbadmin -c "admintools -t start_db -d xxxxdb"
Info: no password specified, using none
Going with traditional slower startup
Spread encryption is enabled. Key rotation will be performed.
- Database config synchronization step failed. Please check logs *
Database xxxxdb did not start successfully: Unable to synchronize database config on all nodes..
Hint: if you use Eon mode, then you may need to start all primary nodes.
admintools.log file is following:
2023-01-06 16:51:29.703 admintools/3870:0x7fd978c37740 [ATFileCopy._copyPathImpl] Copy Failed on x.x.x.x: status=Failure host=x.x.x.x version=vertica.engine.api.at_send_file/1.0.0 content={"runner_ack": true} error_message=file length mismatch 10064 does not match source: 10071
2023-01-06 16:51:29.703 admintools/3870:0x7fd978c37740 [adminExec.synchronizeDatabaseConfig] [synchronize vertica.conf] failure to send to host x.x.x.x
2023-01-06 16:51:29.703 admintools/3870:0x7fd978c37740 [adminExec.dbStart] * Database config synchronization step failed. Please check logs *
2023-01-06 16:51:29.703 admintools/3870:0x7fd978c37740 [commandLineCtrl.startDB] Database xxxxdb did not start successfully: Unable to synchronize database config on all nodes..
Hint: if you use Eon mode, then you may need to start all primary nodes.
Note that. Seems like it is some kind of multibyte char bug. So this length function does not seem to take into account that there may not be only single byte chars.
error_message=file length mismatch 10064 does not match source: 10071
I modified file: /var/lib/vertica/xxxxdb/v_xxxxdb_node0001_catalog/vertica.conf
And removed these two parameters:
LDAPLinkFilterGroup=...
LDAPLinkFilterUser=...
Now database starts fine. And these same rows, that I removed from vertica.conf file, are returned there back.
So if I restart database again, I will get same error.
Raul
