Skip to main content

Vertica DB wont start

  • February 22, 2016
  • 2 replies
  • 15 views

Had-Z

[dbadmin@node2 opt]$ admintools -t start_db -d VMart;
Info: no password specified, using none
Error: it appears as if the vertica process is stillrunning on the following hosts: []
please wait until the process exits before startingthe database.
[dbadmin@node2 opt]$

 

database is not starting , its a 3 nodes cluster , 3 VM on my laptop it was working before but probably didnt do a proper shutdown and now its failing to start , from admintools UI nothing happens when i try to start it . 

 

2 replies

SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • February 22, 2016

Hi,

 

 

       Can you run ps -ef|grep vertica from all nodes and share me the output

 

Sruthi


Adrian_Oprea_1
Forum|alt.badge.img+1
  • Participating Frequently
  • February 22, 2016

 

 Are your ip address the same ? on your virtual hosts ?

 

What does your logs say ?

/opt/vertica/log/adminTools.log

/vertica/catalog/<db_name>/v_<db_name>_<node>_catalog/startup.log

 

It might be very easy thing ! 95% of the times the logs will help you solve it.

 

 or wipeout all Vertica pids on all hosts

ps -ef | grep vertica |grep -v grep |awk '{print "kill -9 "$2}'