Skip to main content
Question

vertica full backup external fails with below error

  • January 14, 2020
  • 6 replies
  • 22 views

msanjib
Forum|alt.badge.img+1

vbr.py -t backup -c backup_restore_full_external.ini
Enter vertica password:
Error: Manifest not found at rsync://[x.x.x.x]:50000/home/verticauser/backups/ -- is the backup location initialized? Hint: Execute '--task init' first.

Backup FAILED.

Vertica Version :v9.2.1-0
rsync : rsync version 3.1.2
Note: The pwdless ssh is properly set.
==============================Log snippets============
The rsync connection and file initialization:

2020/01/14 12:36:09 [2396] rsync on vbr/home/verticauser/backup_manifest from UNKNOWN (source IP )
2020/01/14 12:36:09 [2396] building file list
2020/01/14 12:36:09 [2396] rsync: link_stat "/home/verticauser/backup_manifest" (in vbr) failed: No such file or directory (2)
2020/01/14 12:57:33 [2455] name lookup failed for source IP: Name or service not known
/

Note1: Is it mandatory to have name lookup for rsync? I have added the host names in both source and target and do't see the above error.
However now I see the error below.
2020/01/14 12:58:21 [2457] rsync on vbr/home/verticauser/backups/backup_manifest from UNKNOWN (source ip)
2020/01/14 12:58:21 [2457] building file list
2020/01/14 12:58:21 [2457] rsync: link_stat "/home/verticauser/backups/backup_manifest" (in vbr) failed: No such file or directory (

6 replies

msanjib
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • January 14, 2020

In fact, I was testing the rsync working using manual command it works fine.
Manual:

rsync -v -v -e 'ssh -p 22' myconfig.conf verticauser@x.x.x.x:/home/verticauser

opening connection using: ssh -p 22 -l verticauser 192.168.220.141 rsync --server -vve.LsfxC . /home/verticauser (11 args)
delta-transmission enabled
myconfig.conf
total: matches=0 hash_hits=0 false_alarms=0 data=0

sent 87 bytes received 66 bytes 102.00 bytes/sec
total size is 0 speedup is 0.00

vbr script error:

2020/01/14 14:28:04 [2812] connect from hostname (x.x.x.x)
2020/01/14 14:28:04 [2812] rsync on vbr/home/verticauser/backups/backup_manifest from hostname (x.x.x.x)
2020/01/14 14:28:04 [2812] building file list
2020/01/14 14:28:04 [2812] rsync: link_stat "/home/verticauser/backups/backup_manifest" (in vbr) failed: No such file or directory (2)


Bryan_H
Forum|alt.badge.img+2
  • Participating Frequently
  • January 14, 2020

Is this the first time running backup to this location or INI file definition? If so, run the initialization task: vbr -t init -c backup_restore_full_external.ini


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • January 15, 2020

@msanjib Can you share me the output of the following command

vbr -t quick-check -c backup_restore_full_external.ini


msanjib
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • January 18, 2020

Thanks Bryan and Sruthi for the help!!
I have a follow up question on replication from one 3 node cluster to another similar 3 node cluster. This is for a disaster requirement for high volume security data generated using MF product only. I would like to replicate/sync data from the cluster(dc) to cluster(dr) across the WAN. Will this same vbr python script help?
The bandwidth and latency requirement will be taken care as per requirement.
I still need to test the replication part of this script and its requirement. An early feedback will be really appreciated.
Thanks in advance,
Cheers,
Sanjib


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • January 18, 2020

Yes.. same vbr script will help. you need to pass replicate for tool option of vbr script. Please visit the below link for more information and prerequisites required on how to replicate to another cluster.

vbr -t replicate -c configfile.ini
https://www.vertica.com/docs/9.2.x/HTML/Content/Authoring/AdministratorsGuide/BackupRestore/ReplicatingtoanAlternateCluster.htm


LenoyJ
Forum|alt.badge.img+1
  • Participating Frequently
  • January 18, 2020