Skip to main content

Vertica install on centos

  • April 7, 2016
  • 12 replies
  • 40 views

Hassan15432

i am receving this error while installing vertica 7.2.2-1 on Centos any idea?!!!

 

 

Error: 'NoneType' object has no attribute 'split'
Traceback (most recent call last):
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/install/__init__.py", line 1171, in run_install
options = option_parser()
File "/opt/vertica/share/eggs/vertica/install/__main__.py", line 255, in _parse_options
_include_ami_customization(parser, options)
File "/opt/vertica/share/eggs/vertica/install/__main__.py", line 264, in _include_ami_customization
cfg_checker.load()
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/install/ami_install_config.py", line 18, in load
self._meta_data.load(base_url)
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/system/aws_metadata.py", line 76, in load
self._harvest_metadata(meta_data_baseurl)
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/system/aws_metadata.py", line 93, in _harvest_metadata
meta_data_baseurl)
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/system/aws_metadata.py", line 207, in _get_macs
raw_macs = raw_macs.split()
AttributeError: 'NoneType' object has no attribute 'split'
Installation FAILED with errors.

12 replies

ashwini1
  • New Participant
  • April 25, 2016

Hi,

 

Even I am facing the same issue. Could someone please help.

 

Thanks!


Chris_Daly_HPE
Forum|alt.badge.img
  • Participating Frequently
  • May 10, 2016

Hi, can you please provide the version of Centos that you are running?

 

Thanks,

-Chris


EskoP
  • New Participant
  • August 31, 2016

We have the same issue on CentOS release 6.8 (Final)

 

It seems like the script in question (aws_metadata.py) tries to connect to  http://169.254.169.254/latest/meta-data/network/interfaces/macs but gets 404 as a result

 

 

 

 


Buelent
  • New Participant
  • September 2, 2016

I am having the same issue with:

 

Vertica Analytic Database 7.2.3-0 Installation Tool

 

Running on OpenStack, withCentOS Linux release 7.2.1511 (Core) and Kernel 3.10.0-327.13.1.el7.x86_64.

 

I have downloaded vertica-7.2.3-0.x86_64.RHEL6.rpm.

 

The Error Message is:

 

Error: 'NoneType' object has no attribute 'split'
Traceback (most recent call last):
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/install/__init__.py", line 1169, in run_install
options = option_parser()
File "/opt/vertica/share/eggs/vertica/install/__main__.py", line 255, in _parse_options
_include_ami_customization(parser, options)
File "/opt/vertica/share/eggs/vertica/install/__main__.py", line 264, in _include_ami_customization
cfg_checker.load()
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/install/ami_install_config.py", line 18, in load
self._meta_data.load(base_url)
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/system/aws_metadata.py", line 76, in load
self._harvest_metadata(meta_data_baseurl)
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/system/aws_metadata.py", line 93, in _harvest_metadata
meta_data_baseurl)
File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/system/aws_metadata.py", line 207, in _get_macs
raw_macs = raw_macs.split()
AttributeError: 'NoneType' object has no attribute 'split'
Installation FAILED with errors.

Installation stopped before any changes were made.


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • September 2, 2016

Can you try to install using --ignore-install-config parameter along with other parameters


EskoP
  • New Participant
  • September 2, 2016

With --ignore-install-config  the upgrade was successful

 

Cheers,


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • September 2, 2016

good to know that issue is resolved


Dave_2
  • New Participant
  • September 21, 2016

Can you please explain what this switch is doing, and why this apparently solves the problem?  We are experiencing this same problem at some of our customer sites.  I should mention that we are seeing this issue even with Rel 7.2.3-7.

 

Thanks!


SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • September 21, 2016

-ignore-install-config will skip the metadata check which is failing.


Nimmi_gupta
Forum|alt.badge.img
  • Participating Frequently
  • September 21, 2016

If you have tried to install vertica with --ignore-install-config  and still complaining about below error

 

Unexpected error: 'NoneType' object has no attribute 'split' 

 

Other option would be to modify the file.

 

Vi /opt/vertica/share/eggs/vertica/install/__main__.py and search for _include_ami_customization(parser, options) and comment out this line.

 

So the steps would be 

1. Rename existing /opt/vertica/share/eggs/vertica/install/__main__.py to __main__.py.ORIGINAL

2. Update  __main__.py file to /opt/vertica/share/eggs/vertica/install/ -  comment out the AWS check in this.

Verify permissions and ownership are as follows

-rw-r--r-- 1 root root 13479 __main__.py

3. Re run install_vertica

 

 


sinorch
  • New Participant
  • January 18, 2017

Hi Nimmi,

 

I have commented out the line showing red below inside /opt/vertica/share/eggs/vertica/install/__main__.py

and re-run install_vertica script, this time script execution started however at the end I got the following error which is the same error actually. 

 

HALT (U9999): https://my.vertica.com/docs/8.0.x/HTML/index.htm#cshid=U9999
 Unexpected error: 'NoneType' object has no attribute 'split'

 

if options.debug:
vertica.shared.logging.set_debug_level()

_include_ami_customization(parser, options)

return options

 

Do you have an idea on this?

 

Gokhan


Zolee
  • New Participant
  • June 20, 2017

Hey guys,

Took me a while, but found a solution. The root of the problem is that if you are installing Vertica on OpenStack it will have a metadata server (169.254.169.254), and if the install python script gets a response from it, it assumes its running under AWS, so it will request AWS specific metadata which doesnt exist, so it gets no response from the OpenStack metadata server.

To fix the issue issue you have to edit the aws_metadata.py (/opt/vertica/oss/ python/lib/python2.7/site-ackages/vertica/system/aws_metadata.py) file. Inside the load function (def load, not in the def init) replace the self.is_aws part to

       "self.is_aws = False"

This way the installation won't think you are under AWS.

Hope this helps :)

Zolee