Skip to main content

Vertica IP For single Node Cluster

  • June 10, 2015
  • 2 replies
  • 15 views

Madhusudhan_08

Hi 

 

Can some one help me in changing the IP address of Vertica 7.1 for the single node. I have gone through different docs available online all are showing for multiple nodes but not for single node

 

Thanks in Advance 

 

Madhu

2 replies

Shobhit_Garg
Forum|alt.badge.img
  • Participating Frequently
  • July 16, 2015

Hi,

 

Changing IP of a single node cluster in not supported in HP vertica. As the node IP get stored in database catalog.

 

Thanks,

Shobhit


sKwa
Forum|alt.badge.img+1
  • Participating Frequently
  • July 18, 2015

Hi!

 

 

Why your IP for a single node cluster isn't localhost or 127.0.0.1?

Why you need to modify it?

 

Installing the HP Vertica Database at the Command Line

...

On a single-node installation, consider using the host name or IP address instead of localhost or 127.0.0.1 because of the following limitations:

  • The -s parameter is required for multi-node installations. On single-node installations the parameter is optional, and the default is localhost. However, if you plan to expand to additional hosts later, you must use the -s parameter. If you do not use the -s parameter, your HP Vertica installation cannot be upgraded to a multi-node deployment.
  • On a single-node localhost installation, the installer does not set up a passwordless ssh. HP Vertica's backup scripts require that the administrator be able to log into the node via ssh without a password. Consequently, if you want to use the backup scripts, you must manually enable passwordless ssh logins for any single-node installation.
  • If either side of a connection is a single-node cluster installed to localhost, importing and exporting data fails. Failure also occurs if you do not specify a host name or IP address for your single-node cluster.

...