Skip to main content
Question

Vertica Node would not start - LOST CONTACT

  • June 12, 2025
  • 2 replies
  • 6 views

dimitri_p
Forum|alt.badge.img+2

On Vertica 12 one of the nodes went down and when trying to re-start vertica on the host we get LOST CONTACT in Admintools.

We get this in Vertica.log (and no other errors):

2025-06-11 20:28:45.303 RecoverTable:0x7feb1effd700-16000000000093f [Txn] <INFO> dropping partitioned StorageContainer (ROS): 0x16000001ae9658d
2025-06-11 20:28:45.306 EEThread:0x7fe7cf7fe700-16000000000091e [Main] <PANIC> Received fatal signal SIGSEGV.
2025-06-11 20:28:45.306 EEThread:0x7fe7cf7fe700-16000000000091e [Main] <PANIC> Info: si_code: 1, si_pid: 1183312701, si_uid: 0, si_addr: 0x4687eb3d

and this in ErrorReport.txt

Restart Vertica on host and Restart Cluster do not help, we always end up with one node down.

Any idea what else to try?

2 replies

SruthiA
Forum|alt.badge.img+1
  • Participating Frequently
  • June 12, 2025

please raise a support case. it may be a bug.


dimitri_p
Forum|alt.badge.img+2
  • Author
  • Participating Frequently
  • June 24, 2025

In case you've found this post using Search and are having the same issue, we've fixed ours by formatting the data filesystem on the problematic node and having the node recovered by the rest of the cluster (restart Vertica on Host). So it looks like it was some sort of metadata corruption that vertica couldn't handle automatically.