Skip to main content

Vertica ODBC Driver 7.1.1 compatibility issue with SAP BO 3.1 SP5

  • June 25, 2015
  • 6 replies
  • 32 views

Chandra_Prakash
Forum|alt.badge.img+1

Hello Vertica Team,

 

we recently migrated from Vertica 5.0 to Vertica 7.1.x and before migration we were using vertica ODBC driver 4.0.24 version to connect with SAP BO 3.1 SP5.

 

after migration, new odbc 7.1 is not supporting to connect with SAP BO 3.1 SP5.

 

error: BO Universe designer crashes and automatically gets closed. 

the same error was encountered 5 years back while first time Vertica set up with 5.0 and odbc driver 4.1.17 was used but vertica team suggested to use driver 4.0.24 version.

 

Any suggestion, which odbc driver version will support (Vertica DB version 7.1.1.x) with SAP BO 3.1 SP5?

 

 

Regards,

CP

6 replies

PraJain
  • New Participant
  • June 29, 2015

Hi Chandra,

 

We have tested Vertica ODBC driver 7.1.1 with SAP BO 3.1 SP5 and did not find any issue.

 

Does BO Designer provides any information when it crashes - error code or any logs?

Is it crashing while connecting to Vertica or doing some other operation like inserting tables?

 

Please provide more information so that we can create a reproducer to debug the issue that you are facing.

 

Thanks

Praveen

 


jllamas
  • New Participant
  • July 1, 2015

Chandra_Prakash,

 

You need to edit the odbc.prm file

C:\Program Files (x86)\Business Objects\BusinessObjects Enterprise 12.0\win32_x86\dataAccess\connectionServer\odbc\odbc.prm

 

and set the two following parameters to N

 

        <Parameter Name="OWNER">N</Parameter>
        <Parameter Name="QUALIFIER">N</Parameter>

 

Designer 3.1 should work fine again after setting those parameters.

 

Kind regards,

Jaime.


Chandra_Prakash
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • July 1, 2015

Thanks Jaime. I will try this tomorrow and let you know the results.

 

Regards,

CP


Chandra_Prakash
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • July 2, 2015

Hi Jaime,

It is working perfactly fine. Thank you very much for your help.

 

 

Regards,

CP


Chandra_Prakash
Forum|alt.badge.img+1
  • Author
  • Participating Frequently
  • July 7, 2015

Hi Jaime,

After chaning the prm file, we have encountered another issue due to flag N.

Unable to change the table onwer. the field itself is disabled.

 

Any help is much appreciated.

 

Attached, find the screen shot.


jllamas
  • New Participant
  • July 7, 2015

 

You can try setting the OWNER parameter back to 'Y', I am not sure if both parameters are needed to be set as 'N'.

 

In case the parameter is really needed, you use the following workarounds.

- Change the universe connection to a non-ODBC type (oracle or similar), change the owner, revert the connection to vertica ODBC.

- Leave owner blank for your table definitions and use the HP Vertica "search paths" to determine the schemas where the user will look for the table. If you provide a list of schemas for a given user, then the queries will look in order inside those schemas until they find the table with the correct name.

 

Have a look here for more detailed info about search paths:

https://my.vertica.com/docs/7.1.x/HTML/index.htm#Authoring/AdministratorsGuide/ConfiguringTheDB/SettingSchemaSearchPaths.htm%3FTocPath%3DAdministrator%27s%2520Guide|Configuring%2520the%2520Database|Designing%2520a%2520Logical%2520Schema|Using%2520Multiple%2520Schemas|_____4

 

Best Regards,

Jaime.