When I was using vertica 9.2 users were granted permission by GRANT ALL ON ALL TABLES IN SCHEMA <> to <> and had no issues with normal DML activity. However in vertica 10 gettting "ERROR: Failed to create default key projections for table "USER_X"."TABLEHEADER": Permission denied for schema USER_X. Issue was resolved by granting create privilege on schema to the user/role. Do we need to grant create privilge on schema to user for executing DML ?
Sign up
Already have an account? Login
Welcome to the Rocket Forum!
Please log in or register:
Employee Login | Registration Member Login | RegistrationEnter your E-mail address. We'll send you an e-mail with instructions to reset your password.