Hi everyone
One of our client just updated Vertica to v 12.0.3 and one of our historical etl job started to failed .
The etl job creates a temporary table , withCREATE LOCAL TEMPORARY TABLE... ON COMMIT PRESERVE ROWS and stores data from a SQL Server.
During the insert into temporary table in Vertica , the etl job fails with this syntax:
ERROR: Too many ROS containers exist for the following projections: v_temp_schema.tempControll_3fdd282e03132378_b0 (limit = 67323, ROS files = 67321, DV files = 0, new files = 23) v_temp_schema.tempControll_3fdd282e03132378_b1 (limit = 67323, ROS files = 67321, DV files = 0, new files = 23)
In the past I had the same problem , but only on production tables and we forced with SELECT DO_TM_TASK('mergeout', 't1' , and Vertica was not updated to version 12.0.3
I know that WOS usage has been deprecated , but I don't figure out what's the problem with this scenario.
MergeOutInterval' --> 600
ContainersPerProjectionLimit' --> 1024
Can anyone help me out?