Skip to main content
Question

Why error occured When i use purge_table([table_name]) in spring boot project?

  • November 23, 2021
  • 1 reply
  • 5 views

HyeontaeJu
Forum|alt.badge.img+2

When there were 300 million data in the table, purge_table() worked normally, but when it increased to 450 million, the following error occurred.
I would like to hear the solution when the following error message occurs.

org.springframework.dao.RecoverableDataAccessException: 
### Error querying database.  Cause: java.sql.SQLRecoverableException: [Vertica][VJDBC](100024) IOException while communicating with server: java.io.EOFException.
### The error may exist in class path resource [mybatis/mapper/ros/ROSManageMapper.xml]
### The error may involve defaultParameterMap
### The error occurred while setting parameters
### SQL: SELECT public.purge_table(?)
### Cause: java.sql.SQLRecoverableException: [Vertica][VJDBC](100024) IOException while communicating with server: java.io.EOFException.
; [Vertica][VJDBC](100024) IOException while communicating with server: java.io.EOFException.; nested exception is java.sql.SQLRecoverableException: [Vertica][VJDBC](100024) IOException while communicating with server: java.io.EOFException.
### Error querying database.  Cause: java.sql.SQLRecoverableException: [Vertica][VJDBC](100024) IOException while communicating with server: java.io.EOFException.
### The error may exist in class path resource [mybatis/mapper/ros/ROSManageMapper.xml]
### The error may involve defaultParameterMap
### The error occurred while setting parameters
### SQL: SELECT public.purge_table(?)
### Cause: java.sql.SQLRecoverableException: [Vertica][VJDBC](100024) IOException while communicating with server: java.io.EOFException.
; [Vertica][VJDBC](100024) IOException while communicating with server: java.io.EOFException.; nested exception is java.sql.SQLRecoverableException: [Vertica][VJDBC](100024) IOException while communicating with server: java.io.EOFException.

1 reply

HyeontaeJu
Forum|alt.badge.img+2
  • Author
  • Participating Frequently
  • November 25, 2021

i solve this problem by resetting keepalive attribute in os level

echo 600 > /proc/sys/net/ipv4/tcp_keepalive_time
echo 60 > /proc/sys/net/ipv4/tcp_keepalive_intvl
echo 20 > /proc/sys/net/ipv4/tcp_keepalive_probes